PDA

View Full Version : When on Bootcamp my computer doesn't recognize my Logitech Z-5500




Huddle
Dec 26, 2012, 11:13 AM
When I'm on Mac the speaker system works just fine, but when I got to bootcamp and plug it in it doesn't realize that it is plugged in. It just plays the sound through the in-built speakers. I'm using an optical sound cable, this is on a Windows 7 partition and the computer is a late 2011 MacBook Pro. Any help is greatly appreciated.

----------

Also, if you go onto Logitech's site it says that you don't need special updates to your sound drivers, and that the system should be able to run through the cable and nothing else.



Huddle
Dec 26, 2012, 11:58 AM
460 views, wait what?

Tomorrow
Dec 26, 2012, 12:01 PM
It could be because you're plugging/unplugging the cable. I'm using an older iMac, and because it's a desktop I never unplug the speaker cable - but I also don't have problems with sound going back and forth between the two OS's, either in Boot Camp or through Fusion.

When you're in Windows, what device is the OS using for sound output? You might have to set it to optical out.

Huddle
Dec 26, 2012, 12:09 PM
It could be because you're plugging/unplugging the cable. I'm using an older iMac, and because it's a desktop I never unplug the speaker cable - but I also don't have problems with sound going back and forth between the two OS's, either in Boot Camp or through Fusion.

When you're in Windows, what device is the OS using for sound output? You might have to set it to optical out.

It is using the laptop speakers, how do I go about setting it to optical out? Thanks a lot for the help.

Tomorrow
Dec 26, 2012, 01:16 PM
I don't have Windows 7 on my iMac, so I'm looking on a different computer. Under Control Panel select Sound, then the Playback tab. Check to see which is the default device. You should have an option for optical out, set that as your default.

Huddle
Dec 26, 2012, 01:30 PM
I don't have Windows 7 on my iMac, so I'm looking on a different computer. Under Control Panel select Sound, then the Playback tab. Check to see which is the default device. You should have an option for optical out, set that as your default.

I don't see that option, could you show via. a screenshot or something like that. I was unable to find it.

Tomorrow
Dec 26, 2012, 03:02 PM
I don't see that option, could you show via. a screenshot or something like that. I was unable to find it.

I can't. The only Windows 7 computer I have access to is my PC laptop which doesn't have any optical audio hardware. But if the device isn't listed, then chances are you don't have the Windows drivers installed for it.

Huddle
Dec 26, 2012, 03:39 PM
I can't. The only Windows 7 computer I have access to is my PC laptop which doesn't have any optical audio hardware. But if the device isn't listed, then chances are you don't have the Windows drivers installed for it.

That's the thing, it says on logitechs site that you don't need additional drivers for it to work.

Tomorrow
Dec 26, 2012, 04:50 PM
That's the thing, it says on logitechs site that you don't need additional drivers for it to work.

I'm not talking about the speakers, I'm talking about the computer's hardware. The audio out port is capable of regular old stereo out through a 3.5 mm audio connector, or digital 5.1 out through an optical mini TOSLINK connector. They just happen to use the same opening on your MBP, but they're two different hardware devices, at least as far as the OS is concerned.