PDA

View Full Version : Selecting Wireless Networks


ColoJohnBoy
Sep 26, 2005, 08:20 PM
I've had my PowerBook set to, by default, to join a specific wireless network, namely 'linksys' as both my roommate and boyfriend have linksys routers. My roommate just switched to a Netgear router, so naturally I want to set AirPort to join the network with the strongest signal. Under 'Network' in 'System Preferences', though, that is no longer an option! The only optino available is 'Join a specific wireless network'. The ability to change settings isn't locked and Help Viewer seems devoid of any pertinent information. Any ideas on how I can change this? Thanks much.

chucknorris
Sep 26, 2005, 08:38 PM
I've had my PowerBook set to, by default, to join a specific wireless network, namely 'linksys' as both my roommate and boyfriend have linksys routers. My roommate just switched to a Netgear router, so naturally I want to set AirPort to join the network with the strongest signal. Under 'Network' in 'System Preferences', though, that is no longer an option! The only optino available is 'Join a specific wireless network'. The ability to change settings isn't locked and Help Viewer seems devoid of any pertinent information. Any ideas on how I can change this? Thanks much.

If you make them both preferred networks, then set airport to join only preferred networks, won't that accomplish the same thing?

I'm pretty sure that airport defaults to the one with the strongest signal, and if not...how hard is it to switch over? (Not at all hard)

ColoJohnBoy
Sep 26, 2005, 08:44 PM
I can't even set it to join preferred networks, or even to designate preferred networks, only to 'Join a specific netwoprk'. This thing has me puzzled and puzzed.

chucknorris
Sep 26, 2005, 08:54 PM
I can't even set it to join preferred networks, or even to designate preferred networks, only to 'Join a specific netwoprk'. This thing has me puzzled and puzzed.

Hmmmm....trash the airport preference files. See if that fixes things.

BTW: What OS are you running?

chucknorris
Sep 26, 2005, 08:55 PM
Whoops! Double post!

JonBoy470
Sep 26, 2005, 10:01 PM
As a general rule, having your laptop automatically join the most powerful network is a heinous security risk.

A common security exploit for an 802.11 network is as follows:

1. Set up a rogue network with the same location and name as an existing network.
2. Laptops to come along and automatically join your network instead of the incumbent network their users think they're joining.
3. Do "bad things" to said users and/or their 'puters. E.g. sniff account information/passwords, exploit OS weaknesses, grab files/personal data etc.

Basically, from a security standpoint it should only be possible for your computer to join "trusted" networks automatically. Absent a "trusted" network, user intervention should be required to insure the user is aware of which network is being joined. Thus, hopefully, the user prevents the computer from joining a rogue network.

ColoJohnBoy
Sep 26, 2005, 11:01 PM
Running 10.4.2 here. I deleted the pref file and restarted, but the setting hasn't changed. Tricky.