PDA

View Full Version : Mobile Account Home Folder Gone!




michelg1970
Dec 31, 2012, 05:19 AM
Hi,

Mac Mini 2011 - Mountain Lion Server (with updates).

On my MBP I can log in on my mobile account and then fully synchronises files with the server.

When I connect (from my MBP) to my server I can access the home folder (read only).

When log in on my server as admin then on the server my Home Folder (my user account) is gone or at least invisible. For the other users the home folders are still there and accessible.

If I try to make a new folder with the same (user) name OS X gives me the error that the folder already exists (although it is not visible).

When I open the Server App and look under File Sharing then my Home Folder is visible however it won't let me change permissions.

Anyone has an idea?

Thanks!
Michel



DJLC
Dec 31, 2012, 07:13 AM
Sounds like the permissions / ACLs on your home folder might've gotten messed up. Double check those...

You might need to use Terminal to check those if Finder isn't being friendly. If you're not familiar, read up on the cd, ls, chown, chgrp, and chmod commands.

michelg1970
Dec 31, 2012, 08:50 AM
Sounds like the permissions / ACLs on your home folder might've gotten messed up. Double check those...

You might need to use Terminal to check those if Finder isn't being friendly. If you're not familiar, read up on the cd, ls, chown, chgrp, and chmod commands.

John, thanks. Am no expert at this. In Server App I can reset and edit permissions for all users except my own account: there's no OK button....

I tried CHOWN but having trouble to formulate it.

Basically I have 1 hard drive with OSX and Apps and Admin Account and 1 hard drive (Server Users) with all the user accounts.

How do I formulate this into terminal? SUDO CHOWN -R Michel /Michel???

Thanks

DJLC
Dec 31, 2012, 09:47 AM
I *think* you'll want to do the following on the server:

cd /Volumes/Server\ Users
sudo chown -R michel:staff Michel
sudo chflags -nohidden Michel

The cd makes the Server Users volume your current directory ("/" always refers to the drive OS X is running on; other drives are presented as directories under Volumes in the root of the system drive). Then chown with the -R flag to apply to subfolders, michel:staff makes you the owner with staff as the group, and the final Michel refers to your home folder. Then the chflags command to make sure it isn't set to be hidden.

Once that's done, you can check the permissions (and compare them to other home folders) by running:
ls -l

*Hopefully* this will set things straight...

michelg1970
Dec 31, 2012, 01:20 PM
Dear John,

It worked!!!! Thanks so much.

I had to fiddle a bit with the sudo commands as it did not recognize my Michel folder. But with your cd example I got it working (sudo chown -R michel:staff /Volumes/Server\ Users/Michel) and same for chflags.

Thanks so much, you saved my day (year).

Happy New Year!

:)