PDA

View Full Version : USB ports stopped working




zign
Jan 8, 2013, 10:53 AM
Hi guys,

Both of my USB ports just stopped working this morning. If I plug anything in, I can still charge devices, but none of them will get recognised. Also, this morning I got a message, that some of my USB ports was drawing too much power and was disabled. At this point I connected the USB to the second port, which stopped working shortly after.

I have done the smc and pram resets. It's a 2011 1.7GHz i5 model.

Any ideas?



Stingray454
Jan 8, 2013, 05:44 PM
You usually don't get that message unless you try to plug three or more units in on the same USB port - I got it myself when connecting an Apple USB keyboard, and then connected a mouse and my phone charger (+ phone) to the two USB slots on the keyboard. It seems whatever you try to connect is using too much power.

If you are only plugging in a single device, I'm guessing you have some kind of short circuit either in the device or in the cable. I'd try with another cable, and if that doesn't solve it, with some other USB device (borrow one from a friend or something).

If you're really unlucky, a broken device that you tried to plug in has caused damage to the USB controller, but let's hope not.

Nermal
Jan 8, 2013, 05:45 PM
Connect a mouse and reboot while holding Option to get into the Startup Manager. See whether the mouse works there.

If yes, it's a software problem. If no, hardware.

ybz90
Jan 8, 2013, 06:20 PM
Did you experience any trouble with it before it stopped working? My Air briefly had an issue where plugging in new USB devices caused the controller to seize up; the system was not stalled, just all USB input devices for a few moments before working. If it is a hardware problem, then it's likely you won't be able to fix it yourself and may need a new logic board.

zign
Jan 9, 2013, 06:03 AM
Well, mystery solved! I plugged a usb mouse in and it worked. Tried my iPhone and it was recognised in iTines. My nexus 4 was plugged in with a cable which doesn't seem to support data (tried a different one and the device was recognised) and my usb ethernet adopter must have died, as it's not being recognised on any other machines.

Thank you for all the suggestions!