PDA

View Full Version : Messages App won't connect to iMessage




RichardC300
Jan 13, 2013, 10:01 PM
This started 2 or 3 weeks ago, but it hasn't seemed to fix itself. I can't login to my iMessage account on the Messages app!

http://i.imgur.com/zOdI2.png



Avatarshark
Jan 14, 2013, 04:10 PM
Have you tried looking in the System Preference to make sure that you have the user information correct? If all else fail, reinstall Mountain Lion.

Graeme43
Jan 15, 2013, 12:36 PM
I am plagued with this now even though its been working perfect since 10.8 got released :(

autobahns
Jan 16, 2013, 03:27 PM
this happened to me awhile back and caused me about an hour of frustration.

if you haven't fixed it yet, I recommend doing a Finder > Go > Go to Folder > /private/etc/hosts and seeing what you have in there. If you have any clauses blocking verisign servers remove that and save, and restart messages. That fixed it for me.

Hope that helps!

nyolc8
Jan 16, 2013, 04:28 PM
my hosts file is completely default and I have the same problem

Chrysaor
Jan 16, 2013, 09:48 PM
Recently Apple started requiring serial numbers in the EFI for iMessage to work, which also broke iMessage in hackintoshes (its fixed now though).
Did you had any motherboard replacements with no serial numbers on it?

Graeme43
Jan 20, 2013, 04:25 AM
If I go to about this Mac, my serial shows up there and also in the system profile thing :confused:

App store works, gamecenter works, icloud works etc but not iMessage :confused:

justinxtreme
Jan 21, 2013, 05:03 AM
Are any of you using Hackintosh or the Chimera bootloader on your Macs?

If so either install Clover bootloader (an EFI-based bootloader) or uninstall Chimera.

If you install Clover bootloader, you will need to get Chameleon Wizard as well to generate a serial number.

After installing Clover, go into /EFI and open up the config.plist file with TextEdit

Using Chameleon Wizard generate a 11-or-12 digit serial number for the appropriate SMBIOS and put it in there. Add some random numbers on top of the 11-or-12 digit serial number and make it so it is a 17-digit serial number, Clover uses 17-digit serial numbers.

A part of my config.plist looks like this so change the part where it has the serial number on it

<key>RtVariables</key>
<dict>
<key>MLB</key>
<string>C02JK967DHJT21412</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>ProductName</key>
<string>iMac12,1</string>
</dict>

This is a fix for those on a Hackintosh or using the Chimera or Chameleon bootloader.