PDA

View Full Version : Slow Internet on one Mac, fine on the other.




uzit
Jan 18, 2013, 01:19 PM
Hey guys,

I changed my router yesterday as I was getting weak wifi signals with the old one. Everything was fine until this morning where the internet over wifi on my Macbook Air is VERY slow and sometimes it just will not load the website.

We have two iMac', one Windows laptop, Apple TV and all seem to be working fine. Any help?

Thanks



Mlrollin91
Jan 18, 2013, 01:45 PM
I have a very similar problem. I'm using the airport express base station. On my iMac, I'm getting my 18mbps down, but my 2012 MBA, sitting right next to my iMac, only gets 2-4mbps down. If I move my MBA closer to the router I get my 18mbps down. Too me to seems like the MBA wifi range is much smaller than in an iMac or even a MBP for that matter.

Unfortunately I do not have an answer to this, and neither did Apple when I called them. I also took it in and they ran a hardware test on my Airport and Air and both checked out.

Try tweaking your router channels, having it set on automatic probably isn't the best. Experiment with all of them until you find the fastest one (or least amount of nearby routers on that channel).

Goodluck!

uzit
Jan 18, 2013, 02:01 PM
I cant even get to speedtest website to check, It will just load the homepage...sometimes...and thats it :/

gnasher729
Jan 18, 2013, 03:02 PM
I cant even get to speedtest website to check, It will just load the homepage...sometimes...and thats it :/

A thing to check... If one of your neighbours has WiFi without a password, one of your Macs could be using their WiFi by mistake and the other your own router. Check that you are both on the same WiFi network.

Then start System Preferences, select "Network" on both Macs, and compare all the settings.

uzit
Jan 18, 2013, 03:25 PM
Changed the 'channel' on my router....seems to be working....and pretty fast!

Mlrollin91
Jan 18, 2013, 05:46 PM
Changed the 'channel' on my router....seems to be working....and pretty fast!

Glad to hear. Its amazing how other's routers interfere without realizing just because of it being on the same channel. Typically, automatic just reverts to channel 1.

Mrbobb
Jan 18, 2013, 06:14 PM
Changed the 'channel' on my router....seems to be working....and pretty fast!

See that doesn't make sense. Why would a certain channel affect the Mac only but not ur other devices?

Buy oh well as long as it works, until next glitch.

Mlrollin91
Jan 19, 2013, 01:01 AM
See that doesn't make sense. Why would a certain channel affect the Mac only but not ur other devices?

Buy oh well as long as it works, until next glitch.

Because if the MBA is farther away from the router than the other devices, and there are other routers nearby with the same channel frequency, it can confuse the WiFi chip and just interfere. Its weird but it happens.

Mrbobb
Jan 19, 2013, 01:11 AM
Because if the MBA is farther away from the router than the other devices, and there are other routers nearby with the same channel frequency, it can confuse the WiFi chip and just interfere. Its weird but it happens.


Well that's certainly plausible. I just wish people asking WIFI questions give us all their details and we don't have to guess. There are so many variables, we are not there in their environment.

One would think this day and age, WIFI routers' auto channel select would be smarter, but NOOOOooooooo.

Mlrollin91
Jan 19, 2013, 01:29 AM
Well that's certainly plausible. I just wish people asking WIFI questions give us all their details and we don't have to guess. There are so many variables, we are not there in their environment.

One would think this day and age, WIFI routers' auto channel select would be smarter, but NOOOOooooooo.

Completely agree with you on both counts.
I'm surprised that routers pretty much auto-tune to channel 1. They should be able to scan the nearby routers and make sure no signals cross. When AT&T was at my apartment, they said they had 20 routers in the area on channel 1, thats what my Airport was auto-tuned to. Changed it to channel 5 and it was a night and day difference. Crazy.