PDA

View Full Version : Change Password on Encrypted Disk: Invalid Request?




simplebeep
Jan 21, 2013, 03:08 PM
Hi all.

I have an internal hard disk, auxiliary to my startup disk, which is CoreStorage encrypted, originally via diskutil cs. I am trying to change the password to one that is more secure—I dutifully read the manpage and came up with the following command:

cat passwordChg.txt | diskutil cs passwd 52DC2A4E-A74A-409A-B8B4-B440AC4F8686 -stdinpassphrase

where passwordChg.txt contains the old and new passwords separated by newline. Instead of doing anything, diskutil replies:

Started CoreStorage operation
Error: -69886: Invalid request

Huh? I tried several variations (sudo, synonyms for keywords, specifying the passwords on the command line, etc.) which all give precisely the same error. Disk Utility.app offers to change the password, and makes no complaint, but in fact changes nothing.

I have also tried the command with each one of the UUIDs in the coreStorage listing—each of which I'm told "is not a CoreStorage Logical Volume UUID." They are:

|
+-- Logical Volume Group 059FCC6B-DA8D-4590-9D67-4C4CE28FCF02
=========================================================
Name: Tood
Size: 437704826880 B (437.7 GB)
Free Space: 0 B (0 B)
|
+-< Physical Volume 501C67EC-BCB2-4EC6-BAFA-21F72905B5AB
| ----------------------------------------------------
| Index: 0
| Disk: disk1s2
| Status: Online
| Size: 437704826880 B (437.7 GB)
|
+-> Logical Volume Family 7B1C6A95-ED55-476F-B946-D0CC5B63A0FD
----------------------------------------------------------
Encryption Status: Unlocked
Encryption Type: AES-XTS
Conversion Status: Complete
Conversion Direction: -none-
Has Encrypted Extents: Yes
Fully Secure: Yes
Passphrase Required: Yes
|
+-> Logical Volume 52DC2A4E-A74A-409A-B8B4-B440AC4F8686
---------------------------------------------------
Disk: disk4
Status: Online
Size (Total): 437386055680 B (437.4 GB)
Size (Converted): -none-
Revertible: Yes (unlock and decryption required)
LV Name: Bukkit
Volume Name: Bukkit
Content Hint: Apple_HFS

Any ideas or suggestions are greatly appreciated.