PDA

View Full Version : [Resolved] iMac 2012 Wake From Sleep Issues




Macman45
Jan 22, 2013, 01:40 AM
So the new 27" runs great, but instead of shutdown issues, I have wake from sleep problems. The imac runs perfectly, then sleeps at the allotted time fine.

If left for half an hour or so, it will wake normally. If left longer, it takes a couple (sometimes three) taps on the KB to wake it, when it once again runs fine.

Things I've done

SMC / PRAM re-et

Checked Indexing


I have a feeling that because I used MA to transfer my data ( Something I didn't want to do, but was persuaded, by my Apple rep to try) something has come over that should not have.


I should aslo say that the fix is a re-install of ML, but I'd really like to find a better / faster fix if one exists.



Quad5Ny
Jan 22, 2013, 05:06 AM
Can you do a experiment? Try waiting 5 seconds between taps.

The keyboard (if its wireless) may be asleep as well and it needs to wakeup/re-pair itself.

Or more likely, if the 2012 iMac supports standby hibernation what your waiting for is the system to copy the previous contents of your RAM that was copied to your hard drive back to your RAM from your hard drive (RAMception?).

Try a wired keyboard (or mouse). Also Open Terminal, type "pmset -g" and post the output here on the forum.

Macman45
Jan 22, 2013, 08:54 AM
Can you do a experiment? Try waiting 5 seconds between taps.

The keyboard (if its wireless) may be asleep as well and it needs to wakeup/re-pair itself.

Or more likely, if the 2012 iMac supports standby hibernation what your waiting for is the system to copy the previous contents of your RAM that was copied to your hard drive back to your RAM from your hard drive (RAMception?).

Try a wired keyboard (or mouse). Also Open Terminal, type "pmset -g" and post the output here on the forum.

KB is wired...I think a clean install will probably fix this...not a big deal unless it gets worse.

southerndoc
Jan 22, 2013, 09:36 AM
It just takes a while to awaken it. I have a Bluetooth keyboard and trackpad. I can hit the trackpad once and it will awaken, but it takes about 20 seconds.

Quad5Ny
Jan 22, 2013, 09:20 PM
As long as the contents of the RAM haven't been moved over to the hard drive the computer should wake up instantly. That's why I was curious what the "pmset -g" output was (it would have listed the sleep options).

Macman45
Jan 23, 2013, 01:48 AM
As long as the contents of the RAM haven't been moved over to the hard drive the computer should wake up instantly. That's why I was curious what the "pmset -g" output was (it would have listed the sleep options).

I'll have a go later on today...It now seems to wake at random too...I only noticed this last night when I got up for a drink...I'm happy with it particularly the screen so don't want a swap out really...I will probably re-insatll at the weekend.

----------

It just takes a while to awaken it. I have a Bluetooth keyboard and trackpad. I can hit the trackpad once and it will awaken, but it takes about 20 seconds.

Terminal gives the following output:

tandby 1
powerbutton 0
womp 1
halfdim 1
hibernatefile /var/vm/sleepimage
autorestart 0
networkoversleep 0
disksleep 10
sleep 45
autopoweroffdelay 14400
hibernatemode 0
autopoweroff 1
ttyskeepawake 1
displaysleep 30
standbydelay 4200

Quad5Ny
Jan 23, 2013, 02:35 AM
It seems like (http://www.google.com/search?q=2012+pmset+autopoweroffdelay) your not the only (http://netvetsite.blogspot.com/2013/01/macrumors-forums-late-2012-imac-fd.html) one who is noticing (http://www.qnundrum.com/answer.php?q=321052) their 2012 Mac's hibernating (http://translate.google.com/translate?hl=en&sl=de&u=http://www.alexanderwilde.com/2012/09/os-x-how-to-fix-slow-wake-up-time-on-macbook-pro-with-retina/&prev=/search%3Fq%3Dpmset%2Bautopoweroffdelay%26hl%3Den%26client%3Dsafari%26tbo%3Dd%26rls%3Den&sa=X&ei=NJ3_UMGTDsHV0gH4uIC4Cg&ved=0CG4Q7gEwBg). Do you have a SSD (or Fusion Drive)?

Try this: "sudo pmset autopoweroff 0" and "sudo pmset standby 0"

Test your computer for a day with those set. If it solves your problem then you know there is nothing wrong, it was just your iMac Hibernating. :p

If it does not help, then you can still re-install.

P.S. If you like the hibernation, you can switch it back on by re-entering the commands with 1's instead of 0's. You can even change the amount of time by adjusting "autopoweroffdelay" and "standbydelay". :)

Macman45
Jan 23, 2013, 02:45 AM
It seems like (http://www.google.com/search?q=2012+pmset+autopoweroffdelay) your not the only (http://netvetsite.blogspot.com/2013/01/macrumors-forums-late-2012-imac-fd.html) one who is noticing (http://www.qnundrum.com/answer.php?q=321052) their 2012 Mac's hibernating (http://translate.google.com/translate?hl=en&sl=de&u=http://www.alexanderwilde.com/2012/09/os-x-how-to-fix-slow-wake-up-time-on-macbook-pro-with-retina/&prev=/search%3Fq%3Dpmset%2Bautopoweroffdelay%26hl%3Den%26client%3Dsafari%26tbo%3Dd%26rls%3Den&sa=X&ei=NJ3_UMGTDsHV0gH4uIC4Cg&ved=0CG4Q7gEwBg). Do you have a SSD (or Fusion Drive)?

Try this: "sudo pmset autopoweroff 0" and "sudo pmset standby 0"

Test your computer for a day with those set. If it solves your problem then you know there is nothing wrong, it was just your iMac Hibernating. :p

If it does not help, then you can still re-install. :)

I will give that a shot....But I fear a reinstall is on the cards:)

----------

I will give that a shot....But I fear a reinstall is on the cards:)

It's the 3TB Fusion drive

----------

All now set to 0. Will leave it today and see, I do prefer it to sleep at night...guess I can just put them back, but it does seem to be ML related. Anybody running SL on a new IMac?

Macman45
Jan 23, 2013, 05:26 AM
Update.

This may help some people out...As suggested above and using terminal, playing with the values seems to have sorted out my issues. The iMac is now sleeping and waking as it should. Thanks for the tips!:)

Quad5Ny
Jan 23, 2013, 05:32 AM
Edit: Glad everything is working.

---

The iMac should still sleep, it just won't Hibernate (see below).


Sleep/Standby: Machine state is held in RAM, then the computer cuts power to unneeded subsystems and places the RAM into a minimum power state.
Hibernation: Machine state is saved to a Hard Drive and then the computer is turned completely off.
Apple's Hybrid Standby-Hibernation: Machine state is saved to a Hard Drive, then the computer cuts power to unneeded subsystems including RAM.

This last one is what lets MacBook Air's stay "On" with the Lid closed for 30 days. I'm guessing they are now implementing it on other product lines that have SSD's to save energy. The SSD part its important because of how quickly they can copy the saved state back to RAM, HDD's are much slower (also HDD's take precious seconds to spin back up).

I really doubt Snow Leopard will run on the new iMac's without modifying it.

Confuzzzed
Jan 23, 2013, 06:09 AM
Always in awe of people that can do clever things in Terminal! Thanks for the tips

Macman45
Jan 23, 2013, 06:15 AM
Edit: Glad everything is working.

---

The iMac should still sleep, it just won't Hibernate (see below).


Sleep/Standby: Machine state is held in RAM, then the computer cuts power to unneeded subsystems and places the RAM into a minimum power state.
Hibernation: Machine state is saved to a Hard Drive and then the computer is turned completely off.
Apple's Hybrid Standby-Hibernation: Machine state is saved to a Hard Drive, then the computer cuts power to unneeded subsystems including RAM.

This last one is what lets MacBook Air's stay "On" with the Lid closed for 30 days. I'm guessing they are now implementing it on other product lines that have SSD's to save energy. The SSD part its important because of how quickly they can copy the saved state back to RAM, HDD's are much slower (also HDD's take precious seconds to spin back up).

I really doubt Snow Leopard will run on the new iMac's without modifying it.

Nope, I'm going to use Terminal from now on...It's now fine...Wakes as It should after a little more playing around...It wasn't a big deal as thing is perfect in use...Very fast and my old one was top spec in 2011 so it isn't slow.....Now we've nailed it I think...No need for a tedious reinstall...Thanks again!!:)

Macman45
Jan 23, 2013, 06:58 AM
Going to mark this resolved now, but keep it bookmarked...I think it could help a lot of people with the same issues.....threads cropping up all the time on the same topic. I guess Apple will fix it in an update...for now it seems the only way to effectively manage power settings is by using terminal...I have reported the bug to Apple, but I doubt I'm the first...:)

Quad5Ny
Jan 23, 2013, 12:09 PM
Last thing; If for whatever reason you restore a backup of your current iMac to a MacBook Air/Pro, remember to set those two things back to "1".

Macman45
Jan 23, 2013, 11:19 PM
Last thing; If for whatever reason you restore a backup of your current iMac to a MacBook Air/Pro, remember to set those two things back to "1".

:D Spent up until I sell the old one and buy a new rMBP!

JoeBoy73
Feb 19, 2013, 08:32 PM
I'm having the same problem as Macman was...Mac won't wake up properly. Going to sleep on its own...here's my pmset -g info:

Active Profiles:
AC Power 1*
Currently in use:
autorestart 0
powerbutton 1
halfdim 1
panicrestart 157680000
hibernatefile /var/vm/sleepimage
networkoversleep 0
disksleep 10
sleep 10
hibernatemode 0
ttyskeepawake 1
displaysleep 5
womp 1

Macman45
Feb 20, 2013, 03:17 AM
I'm having the same problem as Macman was...Mac won't wake up properly. Going to sleep on its own...here's my pmset -g info:

Active Profiles:
AC Power 1*
Currently in use:
autorestart 0
powerbutton 1
halfdim 1
panicrestart 157680000
hibernatefile /var/vm/sleepimage
networkoversleep 0
disksleep 10
sleep 10
hibernatemode 0
ttyskeepawake 1
displaysleep 5
womp 1



I have now used the terminal fix above on 3 iMacs, all of which had the same issue....using them and setting the power management to prevent hibernation has cured the issue in all three cases.

MacChris87
Apr 29, 2013, 10:22 PM
Here is my pmset -g

Active Profiles:
AC Power -1*
Currently in use:
standby 0
powerbutton 1
womp 1
halfdim 1
hibernatefile /var/vm/sleepimage
autorestart 0
networkoversleep 0
disksleep 10
sleep 10
autopoweroffdelay 14400
hibernatemode 0
autopoweroff 0
ttyskeepawake 1
displaysleep 10
standbydelay 4200

I am running a 2012 iMac with an HDD hard drive. I made both changes suggested on this thread in Terminal and I am still experiencing the problems. What else can I change?

Macman45
May 1, 2013, 12:19 AM
Here is my pmset -g

Active Profiles:
AC Power -1*
Currently in use:
standby 0
powerbutton 1
womp 1
halfdim 1
hibernatefile /var/vm/sleepimage
autorestart 0
networkoversleep 0
disksleep 10
sleep 10
autopoweroffdelay 14400
hibernatemode 0
autopoweroff 0
ttyskeepawake 1
displaysleep 10
standbydelay 4200

I am running a 2012 iMac with an HDD hard drive. I made both changes suggested on this thread in Terminal and I am still experiencing the problems. What else can I change?

Is that the log AFTER you made the changes? If it is, you need to try again. I have had circumstances where I've had to do it twice before the change were properly applied.

asif10
May 21, 2013, 04:40 AM
I am having the same issue with my 2012 macbook pro retina.

I have had some success if i update the time autopoweroffdelay and standbydelay to 36000 (10 hrs), which essentially for me means it will never go to hibernate for me.

So for me, it looks like when it hibernates it doesn't wake up until i do a hard restart a few times.

(Booked in with Apple to see if they can fix this, but looking at some of the post from others, i shouldn't hold my breath)

dfader
Jun 6, 2013, 07:22 AM
Can someone please give a clear set of instructions for solving this problem to a mac dummy? The problems with sleep has been driving me NUTS, and I'd love to have them solved!

Macman45
Jun 7, 2013, 01:46 AM
Can someone please give a clear set of instructions for solving this problem to a mac dummy? The problems with sleep has been driving me NUTS, and I'd love to have them solved!

Open terminal, and type in the following commands ( without the quotation marks )

Using Sudo will probably prompt you for your password...this is the system password that you use on your Mac:: "sudo pmset autopoweroff 0" and "sudo pmset standby 0"

stanem
Aug 6, 2013, 02:46 AM
Hello i am also having problems with sleep on iMac 2012 OS mountain lion, 1 TB fusion drive, first it took about 10 seconds to wake, after trying every tip i could find made things worse, it takes now about 20 seconds and screen is white clean all the time, is there a command that sets every change i made in terminal to stock/factory settings? (Some commands that i tried didnt apply or gave me warning about improper use or result)
I have tried command: "sudo pmset autopoweroff 0" and "sudo pmset standby 0"
sudo pmset -a standbydelay 86400

Guess i ll have to wait for Mavericks to make clean install

Active Profiles:
AC Power -1*
Currently in use:
standby 1
powerbutton 1
womp 1
halfdim 1
hibernatefile /var/vm/sleepimage
autorestart 0
networkoversleep 0
disksleep 10
sleep 180 (sleep prevented by 1120)
autopoweroffdelay 14400
hibernatemode 0
autopoweroff 1
ttyskeepawake 1
displaysleep 10
standbydelay 4200

swiftflo
Sep 24, 2013, 05:24 AM
It seems like (http://www.google.com/search?q=2012+pmset+autopoweroffdelay) your not the only (http://netvetsite.blogspot.com/2013/01/macrumors-forums-late-2012-imac-fd.html) one who is noticing (http://www.qnundrum.com/answer.php?q=321052) their 2012 Mac's hibernating (http://translate.google.com/translate?hl=en&sl=de&u=http://www.alexanderwilde.com/2012/09/os-x-how-to-fix-slow-wake-up-time-on-macbook-pro-with-retina/&prev=/search%3Fq%3Dpmset%2Bautopoweroffdelay%26hl%3Den%26client%3Dsafari%26tbo%3Dd%26rls%3Den&sa=X&ei=NJ3_UMGTDsHV0gH4uIC4Cg&ved=0CG4Q7gEwBg). Do you have a SSD (or Fusion Drive)?

Try this: "sudo pmset autopoweroff 0" and "sudo pmset standby 0"

Test your computer for a day with those set. If it solves your problem then you know there is nothing wrong, it was just your iMac Hibernating. :p

If it does not help, then you can still re-install.

P.S. If you like the hibernation, you can switch it back on by re-entering the commands with 1's instead of 0's. You can even change the amount of time by adjusting "autopoweroffdelay" and "standbydelay". :)

is the O a letter O or a number 0, thanks.

Macman45
Sep 24, 2013, 09:59 AM
is the O a letter O or a number 0, thanks.

It's the numeral zero.:)

swiftflo
Sep 25, 2013, 05:34 AM
It's the numeral zero.:)

Thanks

swiftflo
Oct 16, 2013, 05:20 AM
It's the numeral zero.:)

Thanks for your help, your suggestion cured the problem. No more wake up problems.

steve1812
Oct 21, 2013, 10:04 AM
Changing the pmset thingy numbers for two of the settings worked for me.

I have a 2012iMac with blue tooth key board, hard wired Wacom tablet and a blue tooth touch pad.

The worst I get is around a 5 second delay till the mouse kicks in from the Wacom tablet.
Otherwise insatnt creen no matter how long asleep.

Happy days.

Steve1812

AeroZ
Oct 31, 2013, 04:45 AM
What's the difference between autopoweroff and standby? And what's the difference between autopoweroffdelay and standbydelay? Seems like the same thing

lszl
Nov 19, 2013, 12:14 PM
Hi all!

I recently bought the newest iMac (3.4GHz, 32Gb RAM, 3Tb Fusion Drive) and it did the same thing as it was discussed above. Wake up time was much longer than rebooting, so I've tried the solution provided by you guys. I entered the two command (sudo pmset autopoweroff 0" and "sudo pmset standby 0") and it did resolve the problem, but in quite a strange way. After that I wasn't able to wake the computer with a wired keyboard, just with the power button and strangely a white screen appeared with a progress bar, same as on the MacBooks which are going into hibernation mode. However, even with that the computer woke up much faster than before. I just don't get it how it is possible to be in hibernation mode when that option is turned off by default.
I've figured it out that if I change the standby option back to 1, the white screen disappears and the computer wakes. At this point you might want to ask, so what is the problem then?
The problem is, that I can't wake the iMac with a wired keyboard after a certain amount of time (around 15 minutes). The only way to wake is to push the power button. Which is rather strange in my opinion.
Any idea what causes this? Why it is impossible to wake with a keyboard plugged in?
My pmset -g settings are the following:
Active Profiles:
AC Power -1*
Currently in use:
standby 1
powerbutton 1
womp 1
halfdim 1
hibernatefile /var/vm/sleepimage
autorestart 0
networkoversleep 0
disksleep 10
sleep 0
autopoweroffdelay 14400
hibernatemode 0
autopoweroff 0
ttyskeepawake 1
displaysleep 5
standbydelay 4200

Thank you for your help!
Regards,
L