PDA

View Full Version : Slow OSX SL server file transfer to ML iMac




aicul
Mar 5, 2013, 11:31 AM
I have a pretty basic setup.

Router with fixed IP linked via ethernet to TC. All incomming router traffic is directed via Wifi to iMac Mini SL server with a static IP. The server also provides fileserver facilities to any iMac on the LAN also via Wifi.

I have noticed that the transfer speed for files between the server and any iMac on the LAN is real slow. As if there is some setup problem.

Problem is, I have to my knowledge the setup and cannot find the cause of these massive delays (ie currently 13 minutes for 100Mb on wifi...)

Any advice or pointers could be welcome.



phoenixsan
Mar 5, 2013, 10:38 PM
http://sniptools.com/mac-osx/fix-slow-network-file-transfers-across-mac-osx-lion

https://discussions.apple.com/thread/2132560?start=15&tstart=0

:):apple:

aicul
Mar 6, 2013, 02:17 AM
So I tried a mix of things from related reading. I'm posting it here because they seem to have solved the problem. Or at least reset the iMac in such a way that the problem is not there now.

1. Changed the preferences/network settings to have the Wifi network
- on a fixed Channel number (not automatic)
- not using IPV6 (link)

2. Disconnected all computers, etc from the network and rebooted the network. Then reconnected everything.

3. Applied the below using terminal from an Administrator account
sudo bash -c "echo 'net.inet.tcp.delayed_ack=0' >> /etc/sysctl.conf"
sudo bash -c "echo 'net.inet.tcp.recvspace=40960' >> /etc/sysctl.conf"
sudo bash -c "echo 'net.inet.tcp.rfc1323=0' >> /etc/sysctl.conf"

4. Rebooted the iMac with EPROM reset using CMD+OPT+P+R

This seems to do the job.

Honestly, I am not sure if all the above are necessary, or what step 4 does, but it did do the job.

Thanks for those that pointed me to the related posts