PDA

View Full Version : Partition broke it.




psharp
Mar 7, 2013, 07:54 PM
Hi Macrumors!
There may be a better location for this thread but I couldn't find it as it applies to lots of topics.

In a quest to use a piece of windows software I broke my computer (sort of)
I started by trying to run this software (3ds max) in a vmware fusion install of windows 7. It ran but vmware like to fail, so I quickly gave up. So I decided the next best option was to make a small bootcamp partition. I run through the setup sep get to the partitioning section, it gets about 1/2 way done when the computer kernal panics. (first time since I've gotten the computer.) So I reboot take a look at disk utility, and this has happened:

45gb of space have been removed the the OS Macintosh HD (down to about 205) and been made "available".

Also, and I don't know if this is normal or not, but the drive is no longer OS extended (journaled). I tried partitioning out those 45gb and get the error "target disk is too small for this operation"
here's a screen shot (http://i55.photobucket.com/albums/g134/thepatterofrain/ScreenShot2013-03-08at23523AM_zps44d9b614.jpg)

I'm backed up and good to go and was going to have at it and reformat
but my initial attempt to reformat off the recovery partition doesn't give me an erase option for he entire hard drive. And that's about where I am now
Now the computer works and I'm not totally out of memory yet, but there's still an issue here. Ideally I'd like to stuff those 45gb back into the normal mac partition without reformatting (apple support said it couldn't be done, but the guy didn't really sound very convincing) I'm hoping maybe someone here who a vaster extent of diskutl might be able to shed some light.

I'm in the process of arming myself with a mountain lion install usb which I may use at some point tomorrow, hopefully it will let me completely reformat the drive, I'm scared that it won't though.

Thanks for any help,
Peter

Edit: So booting from an USB install drive also doesn't give me the options to erase the entire disk, at least not with disk utility.



w0lf
Mar 7, 2013, 08:41 PM
Hmm yeah that does seem odd. My first guess would be to try just using diskutil through terminal.

http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/man8/diskutil.8

Probably end up looking like:

diskutil eraseDisk HFS+ "Macintosh HD" disk0

Does that work?

If that doesn't work you could probably try a 3rd party disk aid tool.