PDA

View Full Version : Things aren't refreshing properly




one1
Mar 14, 2013, 03:05 AM
I looked at my clock on my MB running 10.8.2 and it said 7:48pm, but it was 4:01am. The previous time was when I closed my MB. I had to click the time and open the clock preferences for it to update itself, which it did as I opened it. This is just an example of a few other performance issues with refreshing in other areas I am experiencing. I have repaired permissions to no avail. Can I get some further ideas of possibly clearing caches, other permissions to check, etc?



Macman45
Mar 14, 2013, 03:14 AM
Sounds like you are suffering from the well documented "Wake from sleep " issues...More info here:

http://forums.macrumors.com/showthread.php?t=1529750

First we thought that this was confined to Imac's and specifically the new Fusion models, but more and more are reporting it with laptops too. If you prevent hibernation it should help fix the issue.

justperry
Mar 14, 2013, 03:16 AM
I looked at my clock on my MB running 10.8.2 and it said 7:48pm, but it was 4:01am. The previous time was when I closed my MB. I had to click the time and open the clock preferences for it to update itself, which it did as I opened it. This is just an example of a few other performance issues with refreshing in other areas I am experiencing. I have repaired permissions to no avail. Can I get some further ideas of possibly clearing caches, other permissions to check, etc?

If you want to know if this is System wide or User Account related there is a simple way to find out.

Make a new User Account in Users & Groups, then log out of the normal Account and Login into the new one, see how it goes there, if there are no problems there then the normal User Account is affected and can be solved without a reinstall.

OR this:


Sounds like you are suffering from the well documented "Wake from sleep " issues...More info here:

http://forums.macrumors.com/showthread.php?t=1529750

First we thought that this was confined to Imac's and specifically the new Fusion models, but more and more are reporting it with laptops too. If you prevent hibernation it should help fix the issue.

one1
Mar 14, 2013, 03:57 AM
Sounds like you are suffering from the well documented "Wake from sleep " issues...More info here:

http://forums.macrumors.com/showthread.php?t=1529750

First we thought that this was confined to Imac's and specifically the new Fusion models, but more and more are reporting it with laptops too. If you prevent hibernation it should help fix the issue.

Thank you, I have horrible issues with wifi on my iMac when waking from sleep since I switched to lion, then mountain lion. On snow leopard I never had these issues. I'm growing more tired of mtn lion daily. I they don't release a patch that works soon I fear I'll be downgrading all my MacBooks and iMacs to SL.

Macman45
Mar 14, 2013, 04:04 AM
Thank you, I have horrible issues with wifi on my iMac when waking from sleep since I switched to lion, then mountain lion. On snow leopard I never had these issues. I'm growing more tired of mtn lion daily. I they don't release a patch that works soon I fear I'll be downgrading all my MacBooks and iMacs to SL.

It's a known issue and will be fixed..For now, I can gurantee that disabling hibernation will fix you up for now. Your Mac will still sleep, as normal, and you will do no damage by running the terminal commands posted in the link.

I have applied the fix to 3 Mac's now and it's cured all of them.

davidlv
Mar 14, 2013, 11:35 AM
It's a known issue and will be fixed..For now, I can guarantee that disabling hibernation will fix you up for now. Your Mac will still sleep, as normal, and you will do no damage by running the terminal commands posted in the link.
I have applied the fix to 3 Mac's now and it's cured all of them.
Just to make it easy to use the terminal commands, here they are again::cool:
Open a Terminal shell (in the /Applications/Utilities folder)
pmset -g
will list all the current power settings/device settings.
1. set hibernate mode to 0
sudo pmset -a hibernatemode 0
hibernationmode 0 is normal sleep, data kept in ram, nothing written to disk
2. delete the unnecessary sleep file to regain disk space equal to memory (saves the same amount of disk space as your RAM, eg. 8 GBs, valuable on an SSD), since hibernate is disabled
You can use the Go to folder menu to delete the file, found in the /var/vm/ folder, and named sleepimage. Reboot and simply delete that file,. Or use this:
sudo rm /var/vm/sleepimage or sudo rm /private/var/vm/sleepimage
The sleep image file is actually in /Private/var/vm/ but /var/vm/ is a symbolic link to that location.
Optional: Create a blanked zero-byte file so the OS cannot rewrite the file:
sudo touch /private/var/vm/sleepimage
Make the file immutable:
sudo chflags uchg /private/var/vm/sleepimage
3. If pmset -g shows: autopoweroff 1,
disable this automatic hibernation mode (happens even if hibernation mode is set to 0 on the new Mac mini 2012 and iMac)
sudo pmset -a autopoweroff 0
4. set the safe sleep timer (standbydelay) to 20 hours, default is 4200
sudo pmset -a standbydelay 72000
5. sudo pmset -a standby 0
While researching this, I noticed that bit 3 of hibernatemode encourages the dynamic pager to page out inactive pages prior to hibernation. So this appears to be why I have swap used after sleeping (even though my hibernatemode is 0, so bit 3 is off). I disabled this new, possibly buggy behavior by switching off standby: sudo pmset -a standby 0