PDA

View Full Version : Really slow wake for MBP




LeoBloom
Mar 15, 2013, 09:13 AM
13 inch, Mid-2012 MBP with 10.8.2 (12C2034) which I purchased maybe 2 months ago.

I don't know when the issue started but it's been really annoying. When this bug occurs, my wake times are easily 30 seconds to a minute.

Essentially, sometimes when I open the lid I get some or all of the following events in sequence:
1. Greyed out screen with progress bar on the bottom
2. Login screen present but the password cursor isn't blinking and the mouse either can't move or is invisible
3. Cursor appears but still cannot type in the password
4. The screen goes blank for a few seconds
5. Finally, everything reappears, the mouse is responsive and I can type the password

All of this over the course of 30 to 60 seconds.

A bit of research indicated that I should changed the standby delay from 4200 (70 minutes) to something greater. I've tried that - it definitely didn't fix the problem since the bug was still occuring. It may have helped lower the frequency of this bug, but I couldn't tell for sure since the bug is a bit sporadic.

Upon further research, I saw someone mention that I should turn "autopoweroff" to 0 - I've been running the laptop like this for 2 days now and I have not experienced the bug. I can't be sure that this fixed the issue yet because it's only been two days, however, it's been promising.

I'd like to know if you all know what's going on because other people are experiencing this but everyone points to something different. Also, I'd like to know exactly what autopoweroff set to 0 does and if it's bad for the laptop's health.

Also, others have mentioned switching the hibernate mode to 0. What would be the difference in this case between setting hibernatemode to 0 or autopoweroff to 0

http://i.imgur.com/onRBpa1.png



oneMadRssn
May 6, 2013, 05:54 PM
I don't know when the issue started but it's been really annoying. When this bug occurs, my wake times are easily 30 seconds to a minute.

Any update on this?

LeoBloom
May 6, 2013, 06:25 PM
"autopoweroff" to 0 did the trick.

Been running for a month and a half like this with no hiccups.

oneMadRssn
May 6, 2013, 06:27 PM
"autopoweroff" to 0 did the trick.

Been running for a month and a half like this with no hiccups.

Hard to believe that did it. How did you change this setting, or where is it?

LeoBloom
May 6, 2013, 06:29 PM
Do what the reply said

https://discussions.apple.com/thread/4622383?start=0&tstart=0

tmanto02
May 6, 2013, 06:32 PM
I can't help but feel that this going to have other side effects :o

oneMadRssn
May 6, 2013, 06:33 PM
Thanks, hope it helps my issue. Though I have hibernate disabled, so I don't think it will help. Nevertheless, I'm close to out of options so finger's crossed.

LeoBloom
May 6, 2013, 06:39 PM
Shorter battery life - but I charge it every night so I don't care

----------

Thanks, hope it helps my issue. Though I have hibernate disabled, so I don't think it will help. Nevertheless, I'm close to out of options so finger's crossed.

Let us know

oneMadRssn
May 7, 2013, 08:50 AM
Let us know

Well one data point so far: after sleeping (both the computer and me) for ~8 hours overnight, it is not frozen this morning. Huzzah! :D

LeoBloom
May 7, 2013, 11:08 PM
Well one data point so far: after sleeping (both the computer and me) for ~8 hours overnight, it is not frozen this morning. Huzzah! :D

Excellent!

oneMadRssn
May 8, 2013, 09:36 AM
Bleh, it frozen again overnight.

I'm going to try re-enabling hibernate and see if that fixes it.

LeoBloom
May 10, 2013, 07:14 PM
Perhaps if you try out the same settings that I posted in the original post?

oneMadRssn
May 12, 2013, 01:03 PM
I think it's fixed finally. I ended up deleting /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist in order to reset all the pmset stuff I have been messing with back to default. So far so good, it's been a few days with several 4+hr sleeps and no freezes.

badams002
May 17, 2013, 10:08 PM
Looks like most of this is on purpose from Apple to comply with European regulations. It is designed to be a deep sleep starting with OS X 10.8.2 update 2. They talk about it in the support forums on Apple's site. I started experiencing the same thing. I cannot find the support page right now, but it did state that if there is no WIFI, ethernet, or computer activity after 4 hours, it will go into a "deep sleep", and it is normal. Thinking back on it, the days that it happens are days where it is extremely slow on the notification and e-mail front.