PDA

View Full Version : Needing the FILE MacOsX10.5.sdk for FB5




sysgod
Mar 15, 2013, 09:18 AM
Hello,

I have an iMac with MacOs 10.7

I'm trying to run a code (not my own code) written in Future Basic 5, using gcc 4.2 compiler (I already installed XCode 4.5).
All it says (the c compiler) is that a SDK file or path is missing. I got to the point that it says it requires the file MacOsX10.5.sdk or MacOsX10.6.sdk (if I try to compile it for 10.6).

I need that file and cannot get it anywhere. I think I have a MacOs 10.6 DVD (not me, but a coworker). Can I extract it from there? How?

Thanks for any help you can give me.



gnasher729
Mar 15, 2013, 02:26 PM
The latest versions of Xcode don't come with the 10.6 SDK anymore.

Somewhere in the build settings of your project, it says that it wants to use the 10.6 SDK. All you need to do is change that to 10.7 or 10.8 (10.6 SDK was new for MacOS X 10.6; 10.7 SDK for MacOS X 10.7 and 10.8 SDK was new for MacOS X 10.8.

sysgod
Mar 15, 2013, 03:47 PM
It's Future Basic 5... and when configuring the compiler advanced options, the 10.7 option is grayed out. The latest versión it allows to compile for is 10.6, it seems.

It's Future Basic 5... argh...

gnasher729
Mar 15, 2013, 06:16 PM
It's Future Basic 5... and when configuring the compiler advanced options, the 10.7 option is grayed out. The latest versión it allows to compile for is 10.6, it seems.

It's Future Basic 5... argh...

Go to developer.apple.com and download Xcode 4.2. That's the latest version that comes with the 10.6 SDK.