PDA

View Full Version : Messages.app annoying behaviour




iRock1
Mar 17, 2013, 12:31 PM
Let's suppose that I'm watching a YouTube video in fullscreen (i.e. Safari is using its own "space"). If I receive a new message via iMessage, the app is going to be automatically launched and the screen will move (again automatically) to the first space in order to see the new message. This implies that the video will be still playing in the background and that my experience was annoyingly interrupted.

Is there any way to avoid this? Actually I don't want to disable the notifications, but simply avoiding the automatic movement of the screen to the first space, no matter what I'm doing.

Thanks!



unobtainium
Mar 17, 2013, 09:03 PM
Let's suppose that I'm watching a YouTube video in fullscreen (i.e. Safari is using its own "space"). If I receive a new message via iMessage, the app is going to be automatically launched and the screen will move (again automatically) to the first space in order to see the new message. This implies that the video will be still playing in the background and that my experience was annoyingly interrupted.

Is there any way to avoid this? Actually I don't want to disable the notifications, but simply avoiding the automatic movement of the screen to the first space, no matter what I'm doing.

Thanks!

Most video players have an option somewhere in preferences to keep the window on top. Checking that preference should force your video player to always be in front of other windows.

retroneo
Mar 17, 2013, 09:15 PM
Most video players have an option somewhere in preferences to keep the window on top. Checking that preference should force your video player to always be in front of other windows.

He said he's using Safari in fullscreen.

iRock1
Apr 4, 2013, 11:32 AM
He said he's using Safari in fullscreen.

It can be any app actually. I could be using iPhoto in fullscreen and still if I receive a message the screen is going to move automatically to the first space. Really annoying!


Sent from my iPhone using Tapatalk 2