PDA

View Full Version : iPhoto crashes instantly on launch




scottrichardson
Mar 23, 2013, 05:04 PM
Hi all,

For some random reason, my iPhoto will not open. It crashes immediately following launch.

I cannot hold option to choose/create a library - it crashes before that.

I have deleted the library and that does nothing.

I have deleted preferences, which also does nothing.

Lastly, I have re-downloaded iPhoto from the App Store and it still won't work.

I'm running a 2009 Mac Pro Octo 2.93Ghz, 32GB RAM, Sonnet Tempo SSD Pro with 2 x 512GB Samsung SSD Pro in RAID 0, CalDigit USB3 PCI Card, Gigabyte nVidia GeForce 660Ti 2GB running on Mac OS X 10.8.3.

Anyone ever had this happen to them? Any advice or tips are greatly appreciated.

Kind regards,

Scott



scottrichardson
Mar 27, 2013, 05:42 PM
Any ideas? Sorry for the bump

virtuosity
Mar 27, 2013, 08:48 PM
Have you tried repairing file permissions, in Disk Utility?

Also, have you tried to see if the permissions on the Library folder are correct? In Finder, select the iPhoto Library folder. Then choose File > Get Info. Make sure you have full read and write permissions for the folder and then apply this setting to all enclosed items.

scottrichardson
Mar 27, 2013, 09:23 PM
Hi there,

Yes fixed permissions, still no dice.

I even deleted the library and launched iPhoto and it still won't open - it appears to crash before it gets to the point where it looks for a library. As stated, I cannot even hold option to select a library. It crashes before I get that option.