PDA

View Full Version : Limited Users can't run games




stever92
Mar 26, 2013, 03:05 AM
I have an old Indigo iMac which I'm giving away to a family with Primary (elementary) aged children. It is running 10.3.9, has a 500MHz processor and 256MB of RAM. I set up an admin user and then two limited users for the kids.

Everything runs correctly when logged in as the admin but about half the games simply show as the generic Application icon and won't run.

I had all these games stored in a folder on my server and simply copied them across on the network (This all happened at the school where I teach).

I have logged in as both users and studied the permissions via Get Info and tried to alter the kids permissions to match the admin but nothing has worked. I've repaired permissions from disk utility and generally banged my head on the desk, all with no success.

Any ideas?



MisterKeeks
Mar 26, 2013, 05:24 PM
Simply copying the application will not work. Files that the program is dependent on that are not in the .app file will not be present.

stever92
Mar 26, 2013, 10:07 PM
The applications all work when logged in as admin user. The problem only occurs when logged in as a limited user (i.e. as a kid).

I'm pretty certain that it is a permissions issue but have no idea how to fix it.