PDA

View Full Version : iMac G5 hates Leopard




erin330
Mar 30, 2013, 05:57 PM
I got a computer from work with a ton of software, but it is running 10.4.11. I want to get it up to 10.5. I have a Leopard install disc that worked perfectly on a G4, and will also work on an Intel macbook, so I know the disc is ok. When I put it into the G5, the computer spits it out. It will take any other disc, like a movie or software. It specifically hates this disc. So, I made a bootable USB from the disc image, which also works on the macbook and G4. When I restart the G5 with the usb plugged in and hit the option key, it doesn't see the USB. The USB shows up on the desktop, I'll start the installer and hit restart in it, and then it just restarts the computer and does nothing else. Then I tried plugging in an external disc drive. Same deal with the usb, it just restarts, doesn't launch the installer. Doesn't show up when I start with the option key. Then I tried hooking up via firewire the G4 and G5, starting the G4 with the t key. The G5 only sees the G4s HD, not the USB or DVD in it. I haven't tried the firewire deal with the Intel, but I will momentarily. I am not very hopeful.

Ugh ugh ugh!!! Any thoughts? I'm wondering if perhaps there could be some sort of setting, since I haven't erased this computer because I want to keep the software.



erin330
Mar 30, 2013, 07:33 PM
Bizarrely, the intel MacBook solution seems to be working. I'd love to know what the deal is though.

gr8tfly
Mar 30, 2013, 07:46 PM
Does the Leopard disc mount on the desktop on the G5 using either the internal or external disc drive? (It was a little unclear if that happened.) I had a situation like this where neither the internal or external drive would see a disc I burned (this was SL). It turned out the external was just very picky (it's old) and the internal had essentially failed (I ended up replacing it - then it saw the same burned disc just fine).

For the USB drive, try plugging it in after you startup using the "opt" key, when it presents the list of bootable volumes. If the external disc drive is USB, try the same (assuming it's reading your disc ok).

adcx64
Mar 30, 2013, 07:58 PM
Are the universal leopard disks double layered? this could be worth mentioning.

Jessica Lares
Mar 30, 2013, 08:17 PM
You might need a firmware update for the drive. Try putting another DVD and see if it shows up? I had to flash a newer firmware before I got it to work on my Power Mac G5.

erin330
Mar 30, 2013, 09:27 PM
Yep, so the external DVD drive and the USB would mount it.

I've tried DVD movies and software and they are working fine.

The universal leopard disc is a dual layer. I was thinking maybe it had something to do with that, but DVD movies are dual aren't they?

It does now have leopard installed via the intel MacBook.

MisterKeeks
Mar 30, 2013, 10:26 PM
The universal leopard disc is a dual layer. I was thinking maybe it had something to do with that, but DVD movies are dual aren't they?

yes.

g4manimac
Mar 31, 2013, 11:00 AM
I had the same problem two days ago with one of my powerbooks and I know for a fact the dvd drive was working and it spit out leopard EVERY SINGLE TIME no matter what shut it down nothing worked.I ended up having to install it from target disc mode with another of my powerpc's and it installed great and just for good measure I put the leopard disc in after the new install just to see and yeah it worked and I could not tell you what was behind the error.I was also thinking it was a setting because I sometimes fool with the cd/dvd settings when I am burning cd's or dvd's but never could get if figured out,I actually have two 10.5 disc and neither was working.