PDA

View Full Version : New SSD, Issues Restoring from Time Machine (What did I do wrong?)




r2shyyou
Apr 5, 2013, 08:24 AM
Last night, after backing up one last time to my Time Capsule, I replaced the HDD in my mid-2012 13" MacBook Pro (MacBookPro9,2) with a new 500 GB Samsung 840 SSD (and replaced the stock 4 GB of RAM with 16 GB).

Upon booting the machine back up, I was greeted with the 'OS X Internet Recovery' process and let that run until I made it to 'OS X Recovery' in order to access the 'OS X Utilities' screen and, so I'd hoped, restore the new SSD from my latest Time Machine backup.

However, after selecting the option to restore from the TM backup, after which I was able to connect and see the backups successfully, there were no disks to be found.

I realized shortly after that that I needed to format the SSD in order to proceed beyond this point. So I formatted it as "Mac OS Extended (Journaled) and called it, as I figured I should, "Macintosh HD" and restarted the restore process.

After selecting the restore option, I saw what I believed to be my backup in the expected disk (named "Disk") and folder (named "Data") except that one of them (the folder, if I recall correctly) was no longer simply named "Data" but was instead named "Data-1". I proceeded to select it and promptly received an error to the effect of not being able to connect to it. I then backed out and tried a second time only to find that the available folder was now named "Data-2" with the original folder "Data" nowhere to be found and I was still unable to connect to it.

I searched the web using my phone and found the following snippet:

If the replacement has been given the identical name as the original, Time Machine will add a "1" to the name, as in the second sample below.Source: http://pondini.org/TM/E3.html

Since the additional digit, increasing incrementally with each attempt, seemed to be causing the connection problems I was seeing, I re-formatted the hard drive and this time named it "Macintosh SSD" and again attempted to restore from the TM backup. Much to my dismay, the folder name was again changed, this time to "Data-3", and I was still unable to connect in order to restore. I think I tried one more time after doing I-don't-remember-what and made it to "Data-4" before deciding that I wasn't getting anywhere.

Eventually I re-installed OS X Mountain Lion and, once that completed and I created a dummy user account named "admin", I launched Migration Assistant to pull in my previously backed up data/profiles/accounts/what-have-you to that new install. After everything appeared to be back to normal, I deleted the initial "admin" user account and now appear to be "back in business" and where I'd hoped to get initially but in less time and with less steps.

So, if you actually read the above and are reading this now, here are my questions:


Did I go about this whole process incorrectly?
If I did do something wrong, what was it [that I did wrong]?
While everything appears to be running smoothly again, do you know if the process I executed has resulted in anything being left out or am I essentially good to go?
If my process was incorrect and I'm not actually 100% good to go, should I start over by again re-formatting the SSD and correctly restoring from my Time Machine backup?
If I should erase/restore again, what is the proper way to do so?

Kind of a lot of questions following kind of a lot of words but if you have the time and know-how and are willing to answer some or all of these questions for me, I'd very much appreciate it. Thanks!



xlii
Apr 5, 2013, 09:50 AM
I've restored osx from a time machine backup several times with never an issue. The following link walks you through how to do it. Scroll down to "Restore an entire system".

http://www.macworld.com/article/1165784/how_to_restore_data_from_time_machine.html

r2shyyou
Apr 5, 2013, 11:27 AM
I've restored osx from a time machine backup several times with never an issue. The following link walks you through how to do it. Scroll down to "Restore an entire system".

http://www.macworld.com/article/1165784/how_to_restore_data_from_time_machine.html

Thanks, I'll take a look at that in detail when I get home this evening.

However, and this is not for just you, xlii, but for anyone reading this, since it appears to me (me = relative amateur) that my MBP is back up and running essentially normally, does it appear from what I wrote in the post above that there would be any benefit to erasing the SSD and re-restoring from the Time Machine backup the correct way, as noted in the link above? Or did I just go down a longer road to the same end point?

AppleNewton
Apr 5, 2013, 11:51 AM
Another option (not sure if listed in the links, did not verify) is to connect the time machine back-up drive to the MacBook Pro after installing the drive and booting the MacBook Pro, hold the option key and you should see the Time Machine drive listed as an option.

From there it will boot into a recovery mode where it will directly restore your Mac from the back-up and gather the proper OS install.