PDA

View Full Version : Power Mac G5 Not Turning on :-(




iAdvisorUK
Apr 6, 2013, 06:42 AM
I'm new here so I apologise for being a noob, but anyway I recently had to dismantle my Power Mac G5 in order to repair the damaged case.

I had to remove the RAM, the two CPUs and heat-sinks, disconnect the PSU from the motherboard and remove that metal plate that sits on top of the power supply.

After all this I released I didn't need to go any further and did the repair to the case ONLY. I then reinstalled the processors and connected everything back up, and replaced the FX5200 with a Nvidia GeForce 6800 Ultra.

I plugged the power cable back in and pressed the power button on the front I/O, nothing happened, no LED, no chime, no fans, nothing.

I've read elsewhere that it could be the battery but the fact I removed the CPUs and disconnected the power supply seems like a more likely cause of the problem.

Any help would be greatly appreciated,

Cheers



ickystay
Apr 6, 2013, 05:13 PM
Mine would not start once after changing video cards.

What ended up seeming to work was to remove and replace the little battery.

I know it sounds too simple, but it did the trick for me. Good luck!

macalec
Apr 14, 2013, 01:04 PM
Mine would not start once after changing video cards.

What ended up seeming to work was to remove and replace the little battery.

I know it sounds too simple, but it did the trick for me. Good luck!

Try the battery thing, or it could be the power supply is shot. I have had that issue on my G5, thankfully it was within warranty.

MisterKeeks
Apr 14, 2013, 01:39 PM
Try the battery thing, or it could be the power supply is shot. I have had that issue on my G5, thankfully it was within warranty.

Seems like this was a result with repairing, so unlikely that the PSU would die at the same time.

Colpeas
Apr 14, 2013, 04:01 PM
Static electricity is a bitch...

Or, you forgot to plug in some connector.