PDA

View Full Version : Just when I thought it was safe.....




RedRaven571
Apr 10, 2013, 06:31 PM
So, after having reverted to SL for a few months, I decided to reinstall ML using some terminal commands from elsewhere in this forum to make shutdown fast. My shutdown now takes a few seconds, similar to SL, great!

THEN I find out that ML sleeps even when a program is doing something, like burning a disc or converting a video file.

REALLY Apple? Come on!

I'm going to stick with ML this time, but what the hell are they doing at Apple?



w0lf
Apr 10, 2013, 06:45 PM
If you know you're going to be leaving your computer running a task while away for a long time just set the computer to not sleep and sleep the display?

http://km.support.apple.com/library/APPLE/APPLECARE_ALLGEOS/HT5394/en_US/HT5394_00----en.png

Also making a computer not sleep is the job of the program doing the work not the OS. How is OSX supposed to know you don't want it to sleep unless you tell it to...?

ScratchSF
Apr 10, 2013, 08:04 PM
So, after having reverted to SL for a few months, I decided to reinstall ML using some terminal commands from elsewhere in this forum to make shutdown fast. My shutdown now takes a few seconds, similar to SL, great!

THEN I find out that ML sleeps even when a program is doing something, like burning a disc or converting a video file.

REALLY Apple? Come on!

I'm going to stick with ML this time, but what the hell are they doing at Apple?

Came across this in my travels as well. Not ideal, but they changed how override decisions are made by the OS. Seems like you can set the time to "never" (see above post). ML also has a command call Caffeinate, that will help too. See: http://reviews.cnet.com/8301-13727_7-57565272-263/caffeinate-mountain-lion-to-prevent-it-from-sleeping/

Che Castro
Apr 10, 2013, 11:06 PM
Get an app called caffeine

Puts a coffee icon on the status bar you click it to disable sleep settings

On & off

RedRaven571
Apr 11, 2013, 06:45 PM
Also making a computer not sleep is the job of the program doing the work not the OS. How is OSX supposed to know you don't want it to sleep unless you tell it to...?

SL didn't sleep when the computer was performing either activity, using the same apps. SL is OSX, no?

----------

Get an app called caffeine

Puts a coffee icon on the status bar you click it to disable sleep settings

On & off

Yep, Caffeine is a great app. Just these strange, unexpected behavior changes in ML are a little frustrating.

RedRaven571
Apr 11, 2013, 06:57 PM
Came across this in my travels as well. Not ideal, but they changed how override decisions are made by the OS. Seems like you can set the time to "never" (see above post). ML also has a command call Caffeinate, that will help too. See: http://reviews.cnet.com/8301-13727_7-57565272-263/caffeinate-mountain-lion-to-prevent-it-from-sleeping/

Thanks! That was a very helpful link.

iThinkergoiMac
Apr 13, 2013, 10:28 AM
Interesting. I hadn't encountered this before because my Mac doesn't sleep when at home.

Sdreed91
Apr 13, 2013, 08:48 PM
What terminal commands can you enter for faster shut down if I might ask? A faster shut down would be great. Thanks

RedRaven571
Apr 13, 2013, 10:07 PM
What terminal commands can you enter for faster shut down if I might ask? A faster shut down would be great. Thanks

From another thread in this forum, my ML shutdowns are consistently 2-3 seconds after doing the commands below.

Originally Posted by razmarino
type these commands into the terminal window one by one and right after terminal repair permissions in the disc utulity

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 1

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 1