PDA

View Full Version : iTunes skipping on 10.8




ScottishCaptain
Apr 11, 2013, 06:25 PM
I'm just wondering if anyone else has this issue...

Ever since I did a clean install of 10.8, iTunes has been skipping once every ~2 minutes. It is extremely, stupendously, utterly annoying to be sitting here listening to music, in the grove, then blip! Pop and a slight skip.

I never had this issue on 10.6.8 (actually, I didn't have *any* issues on 10.6.8). My entire library is ALAC encoded, but it's not the files. They play fine, if they skip I can immediately rewind and playback the same section of that track and it plays fine. System is playing back through an external sound system via the digital optical audio port.

This issue is basically the mental equivalent of a mosquito buzzing in my ear, but I can't squash it. It totally breaks music immersion and serves as a constant reminder that I'm apparently running a very buggy operating system.

Has anyone ever found out why this happens? I've tried tracking down the issue, but have had absolutely no luck doing so. It's not the disk I/O blocking (which is exceptionally easy to cause in 10.8- but that's another problem entirely). fs_usage shows no relevant filesystem access when the problem occurs (for any process). It's not the system maxing out, it's 99% idle. There's no momentary spikes in Activity Monitor, and I've terminated every non-critical process in the background and the problem still persists.

Specs are in my sig, so I'm pretty sure it's not a "slow computer" problem.

PS: I've filed a bug report with Apple, and I'm aware of the 74 page thread over on the Apple community forums- which are completely useless in that it's just 74 pages of random speculation, praises that 10.8.3 fixed the problem (which it didn't/doesn't), and further complaints that 10.8.3 actually did nothing instead.

-SC