PDA

View Full Version : Change home folder to network location




acochran
Apr 12, 2013, 02:02 PM
Disclaimer - I am a newbie to MAC, but I am an IT Admin all Microsoft based.

Our network consists of an Active directory Server, Exchange, File Server.

I am only setting up 1 mac to our network. This is a new iMac and I have done the steps to add the user to active directory and I can log into the mac using any AD account. I can even mount our "common" folder to the deskto which is a network share of public documents within our company.

How do I make his default home directory point to the network location where all of his personal documents reside?

I am looking for best practices here and do not wish to purchase additional equipment/software because I will not be installing any more macs....


All of our PC users have a group policy for folder redirection for their "My Documents" which are located on the server and it syncs their documents for the Server/Client. How do I mirror this setup for a MAC.

Note - I can do without a group policy enforcement. I just want his documents located on the server so they are backed up every night. Or have it so they sync from his computer to the server (windows Server 2003 32bit)

I have tried going to the user account on the mac and right clicking on the account then changing his home directory to the UNC path of the documents folder on our server, but it did not work once I logged back in.



rlkarren
May 23, 2013, 01:06 AM
I have tried going to the user account on the mac and right clicking on the account then changing his home directory to the UNC path of the documents folder on our server, but it did not work once I logged back in.

This is the right direction. The UNC path must be set in the User Profile on the AD server, in order for Mac OS X to use the UNC path. Otherwise the UNC path is NULL, (IIRC). On the AD Server, make sure the User has the appropriate permissions for the sharepoint and UNC path is set in the user's profile tab. On the Mac Client, Using Directory Utility, highlight Active Directory and then choose Advanced options. Turn Off "Create Mobile Account...", "Force Local Home..." is off, "Use UNC path..." is ON, and SMB is chosen as the protocol. If it doesn't work, it's most likely a permissions issue in the AD server. To test correct permissions, login locally using a different account and try to mount the network home manually using the User's credentials.

This should work, but I am only commenting from memory. If you have time to wade through the information, search for Magic Triangle setup or Golden Triangle setup. You will find the answer there. I have done this in a test environment, but it's been awhile. If you're still interested, I'll see if I can find my notes on this.

Another option is to setup an rsync cron if all you want is his Documents directory. http://benr75.com/pages/using_crontab_mac_os_x_unix_linux

rlk