PDA

View Full Version : My external optical drive is not recognized by my PPC Mac




foz405
Apr 13, 2013, 08:09 AM
I have a OWC external optical drive (read/write) that until today was recognized by my PPC G4 Powerbook. I have tried to connect it by USB, Firewire 400 and Firewire 800, all to no avail. I have tried re-booting etc etc. (by the way, my superdrive is broken). Toast Titanium does not show the alternative drive when I start it up.

To prove the drive works, I connected it to my other PPC G4 Powerbook, and it works.

The machine I am having trouble with is a 17" G4 Titanium PPC. I run 10.4.11, the Mac is a 1.5GHZ PPC G4, with 2GB DDR SD RAM.

What could be wrong ? It has never worked with the firewire 800 port, so I have always used the 400 port. I'm not very technically savvy, being old and grey like my Mac, and would appreciate any assistance.

Regards



justperry
Apr 13, 2013, 08:13 AM
The easiest way to repair this, almost sure it will work, is to download and reapply 10.4.11, you need the Combo update for this and can be downloaded from Apple's site.

foz405
Apr 13, 2013, 08:50 AM
The easiest way to repair this, almost sure it will work, is to download and reapply 10.4.11, you need the Combo update for this and can be downloaded from Apple's site.

Thanks. I've just tried this, and no luck. Anyone with any other suggestions please ?

justperry
Apr 13, 2013, 09:29 AM
Thanks. I've just tried this, and no luck. Anyone with any other suggestions please ?

OK, you can try the following, Open System Profiler, then connect the drive to whatever port you want and see if it shows up under USB or Firewire.
If you have other USB or Firewire devices test them as well, if those work and not the drive then something is really weird.
You might have luck by resetting PRAM and the PMU though.

foz405
Apr 13, 2013, 09:14 PM
OK, you can try the following, Open System Profiler, then connect the drive to whatever port you want and see if it shows up under USB or Firewire.
If you have other USB or Firewire devices test them as well, if those work and not the drive then something is really weird.
You might have luck by resetting PRAM and the PMU though.

Thanks for your trouble. I've connected other devices and they work. I've reset the PRAM but I'm a bit worried about the PMU as Apple warn of dire consequences.
It still doesn't work.
I think the answer is bring out a technician and replace the Superdrive, and then ultimately the whole computer, even though it will be a real pain what with all the old expensive programs I have such as Adobe Creative Suite etc.