PDA

View Full Version : Mac Mini loses WiFi connection




Hookemfins
Apr 16, 2013, 05:41 PM
Late 2012 Mac Mini loses WiFi connection 2-3 times a week. Problem has been happening over the couple of months. When I try to re-connect I am sometimes asked for the WPA pass phrase.

I am up to date using 10.8.3. I'm using a USB keyboard and the Magic Mouse. No other computer has this problem.

I opened network connections and I deleted the WiFi connection. Then I went into advanced and deleted preferred networks. I then added them back in but the problem still persists.

Any ideas on a fix?



Partron22
Apr 16, 2013, 06:24 PM
As you may know, holding down the option key while clicking on the WiFi icon in the menu bar will get you signal strength and other info on your current connection. That's nice, but the System App "Wi-Fi Diagnostics.app" will give you a continuous S/N graph for diagnosing intermittent problems.
In Mountain Lion, the app is found in "System/Library/CoreServices", which can be a pain to get to. When I was having WiFi trouble, I just made an alias to the app, and stored that in my Utility Folder.
Start up Wi-Fi Diagnostics.app, let it generate its little report on your desktop, which can take a while, then select 'Performance' from the Apps' View menu. You'll get a nice window with signal and noise levels. If your signal strength is too close to your noise, you'll need to reposition your router, or your Mac. Otherewise, leave the App running in some forgotten corner of your second monitor until something goes wrong with the WiFi. At that point, you'll likely notice that the noise level spiked just when someone in the house switched on the TV while using the bandsaw in the basement. If that happens repeatably, you'll have a good idea of the source of the problem.

Hookemfins
Apr 17, 2013, 07:53 AM
Thanks for the response. The problem happens mostly when no one is here. Mac and router are fairly close together (5 ft) and with a clear path. I'm logging now and we'll see what happens throughout the day.

blueroom
Apr 17, 2013, 08:13 AM
Thanks for the response. The problem happens mostly when no one is here. Mac and router are fairly close together (5 ft) and with a clear path. I'm logging now and we'll see what happens throughout the day.

Use an Ethernet cable, GigE if your router supports it. Don't clutter up the airwaves if you don't have to.

PS which router model are you using?

Hookemfins
Apr 17, 2013, 04:35 PM
Use an Ethernet cable, GigE if your router supports it. Don't clutter up the airwaves if you don't have to.

PS which router model are you using?


I am going to use an ethernet cable but I'm on a mission as to why this happening, it shouldn't. If I was to take work where I need wireless, I couldn't have it disconnecting. I am running the Wi-Fi diagnostics.

I have a 2 wire gateway (from Uverse) with a dlink DIR 655 piggy backed on top.