PDA

View Full Version : Pismo Boot Issue




FuzzballFury
Apr 17, 2013, 02:55 PM
I picked up a February 2000 Powerbook G3 500 because I've wanted to get a classic Mac for a while and this one was going for cheap. They said it booted to a question mark and when it arrived it was easy to see why, someone had pinched the hard drive. I dropped in a 30GB IBM drive I had (which incidentally was an Apple drive I picked up for an old Wintel machine a couple of years ago).

Holding down C or Option with a retail 9.2.1 disk in the original DVD-ROM drive yielded nothing, and the same thing happens with the drop-in replacement Teac CD-224E drives I grabbed on ebay thinking the DVD drive was cooked. I've tried resetting the PMU and booting with the PRAM battery disconnected. Holding option shows the boot menu with nothing there (pressing the retry button brings the disk drive to life, but nothing ever shows up), and of course nothing is on the blank hard drive (formatted in HFS+).

I checked both memory DIMMs by inserting one at a time, the original 128MB one and an added Hyundai 256MB card. Basically I've tried all the techniques I've accrued from working on computers for a few years, as well as some of the Mac-specific ones and now I've run out of ideas.



ickystay
Apr 17, 2013, 03:09 PM
Do you have another mac you could hook up using firewire target disk mode?

FuzzballFury
Apr 17, 2013, 03:29 PM
I had heard of that method. Unfortunately all of our other Macs are Intel-based.
Although I was able to connect it to my Dad's Macbook and access the hard disk, that was basically the limit to what I could do with it.

ickystay
Apr 17, 2013, 08:12 PM
I see. I just tried to install an old OS X from an intel machine to a firewire drive. No go.

It's been a while, but as I recall, OS 9 was a very simple thing. Installation was not a big deal All you need is a system folder on your hard drive. In order to boot from the 9 disk, it would need its own system folder.

Maybe- get the intel machine hooked up to the Pismo HD. Erase and make sure os 9 driver is checked and reformat to OS Extended (Journaled). Put the install CD into the intel optical drive. Drag the contents from the CD onto the Pismo HD.

Worth a try until someone else comes up with a killer answer.

666sheep
Apr 18, 2013, 03:00 AM
Use "reverse" target disk mode for sharing Intel Mac's ODD:
– put OS install disc in MacBook's ODD
– connect both with FW cable
– boot MB with "T" pressed on kbd
– boot Pismo with "alt" pressed and choose OS install disc which will appear in boot menu
– install and enjoy

jruschme
Apr 18, 2013, 11:55 AM
What happens if you try to boot by holding OPT rather than "C"?

FuzzballFury
Apr 18, 2013, 01:40 PM
What happens if you try to boot by holding OPT rather than "C"?

When I tried that it went to the boot select menu with nothing above it.

I tried copying the System Folder from the CD to the drive, which I was sure to format with Apple Partition Map, in OS Extended, and with the OS9 driver. No dice. I then tried the reverse target disk method, and when it booted I believe it only saw the HD from the Macbook (hard drive icon with a face and the firewire icon below it), and no CD. When I tried booting from it, the screen sat grey for a moment before displaying an image of a floppy disk with a question mark. Probably because Leopard was trying to boot to an unsupported system.

What I'm beginning to think is that there's something more seriously wrong with this machine than I thought.

jpcoelho
Apr 18, 2013, 03:12 PM
I tried copying the System Folder from the CD to the drive, which I was sure to format with Apple Partition Map, in OS Extended, and with the OS9 driver. No dice.

Did you bless the system folder after you copied it to the Pismo hard drive?
If not,you will have to do so before it is recognized as a boot drive...

FuzzballFury
Apr 18, 2013, 05:13 PM
Did you bless the system folder after you copied it to the Pismo hard drive?
If not,you will have to do so before it is recognized as a boot drive...

I'm afraid I'm unaware of how that's done on an OSX system. Is it the same process of dragging "Finder" and "System" out of the folder and then dragging them back?

jpcoelho
Apr 18, 2013, 06:17 PM
I'm afraid I'm unaware of how that's done on an OSX system. Is it the same process of dragging "Finder" and "System" out of the folder and then dragging them back?

yes, that's it... try to do it in target disk mode in your intel machine, and then reboot the Pismo to see if it starts... it worked with mine!

FuzzballFury
Apr 18, 2013, 06:44 PM
Well, I tried to bless the folder several times, it may be a problem with the Intel Macs, I tried to bless it using a command prompt from my MB Pro running 10.8, and using the finder method on my fathers Macbook using 10.5. Neither gave any indication that it had been blessed and the Pismo still would not boot.

I have this strange feeling there might be something wrong with the IO bus on this board, and since it was cheap enough I picked up a tested working board on ebay for $20. If six disc drives fail to boot in the same manner, that's where I become suspicious something else is at fault. This unit was sold as "For Parts or Not Working" so I probably shouldn't have stroked my ego thinking it would be an easy fix. :rolleyes: