PDA

View Full Version : Replaced hard drive cable, boot up time much longer now




-mattias-
Apr 23, 2013, 09:15 AM
Replaced the hard drive cable on my MBP 2010, as the old one was damaged. Before it took about 10 seconds to boot up, but now it takes about 1 minute to boot up. It's also much slower shutting down.

Why is it slower and how can I fix it?



-mattias-
Apr 24, 2013, 10:21 AM
??????

chevelleguy3
Apr 24, 2013, 01:15 PM
Can you give some more info?

You say the old cable was damaged.... was anything else possibly damaged? What caused the damage? (Drop, liquid, etc).

Did you run any updates recently? I've noticed that 10.8.3 takes a bit longer to shut down. Haven't noticed any startup issues.

Was the cable replaced with the correct part number? Not 3rd party generic junk off ebay?

Have you checked the connections of the cable at both the HDD and the logic board to ensure it's got a good connection?

-mattias-
May 1, 2013, 06:16 AM
The cable just stopped worked one day after my MBP had run out of battery.

The new cable was bought off eBay, but it said Foxconn and looked exactly like the one I pulled out.

Don't really know how to check the connections. Can you run any hardware test to test this or something like that? Don't have much knowledge of the hardware, just followed a guide on iFixit.com

And yes, I have 10.8.3.

MrMacMack
May 1, 2013, 06:52 AM
How did you conclude that the issue was with the cable and not something else?

-mattias-
May 1, 2013, 07:30 AM
I got a blinking questionmark at startup. Started a topic on iFixit, and they thought it was most likely the cable, which worked.