PDA

View Full Version : Time Machine "ejects" disk while backing up!?! HELP PLEASE




sap12690
Apr 22, 2013, 10:59 PM
I just bought a 2TB Seagate Hard Drive to back up my iMac. I connected everything up. Turned on Time Machine (first time I try to use it) and selected the disk I want it to back up to. As soon as the countdown starts to start backing up. A message pops up that reads "The disk was not ejected properly" and the hard drive disappears. I have to unplug it and plug it back in for it to show up again in the finder. When I try to run time machine again, the same thing repeats. I do not know what the problem is.... is it the hard drive (Just bought it brand new) or am I doing something wrong? Please help, I just want to start backing up all my stuff. Thanks



macthefork
Apr 23, 2013, 05:57 PM
Reconnect your new Seagate Hard Drive. Go into Disk Utility, (Applications > Utilities > Disk Utility) and select the External Seagate Drive. Make sure the partition map is set to GUID Partition Table, and the Volume is Mac OS Extended (Journaled). If it's not, reformat the Seagate External Drive to those parameters.

Then try Time Machine again.

sap12690
Apr 23, 2013, 07:44 PM
Reconnect your new Seagate Hard Drive. Go into Disk Utility, (Applications > Utilities > Disk Utility) and select the External Seagate Drive. Make sure the partition map is set to GUID Partition Table, and the Volume is Mac OS Extended (Journaled). If it's not, reformat the Seagate External Drive to those parameters.

Then try Time Machine again.

The volume is Mac OS Extended (journaled) so thats fine, however what partition is it supposed to be on?

It says Partision - Current. Then there is a drop down menu with 1, 2, 3, 4.... etc. Which should it be on? It does say its on the GUID Parition Table at the bottom.

THANKS

sap12690
Apr 23, 2013, 08:04 PM
I tired it all again, and its still ejecting the disk. This is so frustrating

macthefork
Apr 24, 2013, 07:11 AM
Looks like you have it formatted properly. The drop down for partition just sets how many partitions you want, so the way you have it set is OK as one partition (current).

You could try another cable to see if that's the problem.

It's unlikely a 2 TB drive is buss powered. However, too much power being drawn from the buss will cause the Mac to disconnect that buss. Are there other items on the same buss drawing power, such as through an un-powered hub?

You can check the Console log in the Utilities folder (Applications > Utilities > Console) to see if that shows any errors on the buss.

It also could be the Seagate drive controller is defective. You could try returning it for a different drive.

g4cube
Apr 24, 2013, 09:37 AM
I tired it all again, and its still ejecting the disk. This is so frustrating

Check here:

http://www.seagate.com/support/downloads/

There are some updates for certain drives.

Woodcrest64
Apr 24, 2013, 09:24 PM
I just bought a 2TB Seagate Hard Drive to back up my iMac. I connected everything up. Turned on Time Machine (first time I try to use it) and selected the disk I want it to back up to. As soon as the countdown starts to start backing up. A message pops up that reads "The disk was not ejected properly" and the hard drive disappears. I have to unplug it and plug it back in for it to show up again in the finder. When I try to run time machine again, the same thing repeats. I do not know what the problem is.... is it the hard drive (Just bought it brand new) or am I doing something wrong? Please help, I just want to start backing up all my stuff. Thanks


Is it USB 3 and how old is your Mac?

sap12690
Apr 25, 2013, 08:45 AM
Is it USB 3 and how old is your Mac?

It is USB 3.0 but it says its 2.0 compatible and my iMac was purchases, in late 2011. i think.

sap12690
Apr 25, 2013, 08:46 AM
Doesnt look like my hard drive is on that list of software upgrades. I did however order a replacement to see if it is the harddrive thats defective. I hope the new one works out fine.

benwiggy
Apr 25, 2013, 09:59 AM
I just bought a 2TB Seagate Hard Drive to back up my iMac. I connected everything up. Turned on Time Machine (first time I try to use it) and selected the disk I want it to back up to.
It's not clear from what you say, but you need to select the 2TB Seagate drive in Time Machine as a backup volume. You don't select the drive whose contents you want to be backed up.

You might want to use Disk Utility to wipe the disk clean. Some manufacturers usually slightly non-standard methods. Either erase the backup volume as HFS Extended, journaled, or partition the DISK (which is the device, not the sub-object in the left hand pane) as 1 partition, HFS Extended, journaled.