PDA

View Full Version : Right Click, Drag and Drop, Stuck Dock




Lastaria
Apr 27, 2013, 12:29 PM
Hi.

I recently started having problem with my mouse. the right click would not work. I also noticed when I went to the dock. The docks magnificent was stuck on the icon I brought the mouse down onto with that icons name. Moving the mouse left and right did not change it. I also noticed if I tried to drag an icon from one location to another, the icon did not drop into the new folder or position, it stayed stuck on the cursor.

I first tried a reinstall using my time machine. then when the problem persisted a clean install but despite this the problem remained.

Looking it up on google I found many with the same issues that were either unresolved, or got resolved but when I followed the same procedure my issues still remained or they found their problem was down to something I do not have like a piece of software or a track pad.

I have tried a Pram Reset Changing the settings having downloaded software that lets you set the mouse keys, booting into guest account.

I believe this is a hardware issue of some sort and not a software issue due to the clean install and also because when I booted into my separate hard drive that runs windows the same problem occurred.

But I am still holding onto the hope there is something I can do to fi this without taking it for repairs.

I run a 2009 Mac Pro (Tower not laptop) and OS 10.8.3

Any help offered would be most appreciated.



smokeyrabbit
Apr 27, 2013, 12:50 PM
Have you tried a different mouse? or another USB port?

Are you saying that the mouse behaves erratically in both Mac OS X and Windows?

Lastaria
Apr 27, 2013, 01:26 PM
Sorry. Knew I missed bits. Yes I tried three different mice and lots of different ports. Same problem.

I have Windows installed on a separate hard drive I placed in a slot in my mac Pro and the same issue with the right click did not work on there.

chown33
Apr 27, 2013, 01:48 PM
If Bluetooth is on, turn it off.

Report back with the results.

Lastaria
Apr 27, 2013, 04:37 PM
Yeah had already tried that. Just done so agin and still not working.

Lastaria
Apr 27, 2013, 05:34 PM
I may have fixed it.

Fingers crossed it wont revert. But I put my computer into sleep mode and then came out again and suddenly everything was working once more.

I will update here in case the problem returns but for now after days of worrying all is fixed.

Thank you to those who offered help.

----------

EDIT: Hmm it did return again. Sending it into sleep mode then coming out fixed it gin. So if this becomes regular feature it will be annoying and I would want a permeant fix. But it is progress.

Lastaria
Apr 28, 2013, 07:05 AM
Okay. It is the next day and the same problem arose. This time however sending the computer to sleep and waking it did not work.

About half an hour later it did work, which makes me wonder if this is some sort of battery issue where something needs a charge. I should lso note the problem kept coming back on a regular basis so I had to put the computer to sleep a lot to fix it.