PDA

View Full Version : Networking a House with Airport Extreme and AT&T Uverse




britboyj
May 8, 2013, 11:34 AM
Hi all!

So my wife and I recently bought a house and I installed all of our stuff after the lengthy process of running ethernet to all but one room (couldn't access it due to attic construction) AT&T Uverse installed their router, and let me do the rest. Currently, the set up is as follows:

Wall ---> [UVERSE] ----> [Airport Extreme BRIDGE MODE] ----> [16 port Switch] ----> Rooms

I turned the wireless in the Uverse box off and set my AE to dual band and all was fine until I noticed my Nest thermostat CONSTANTLY dropped its connection. Thinking this was something to do with the wireless settings, I tried changing channels, making the guest network 802.11b.

After some basic troubleshooting and power cycling, turns out I had no Internet whatsoever. I called Uverse they said there's line issues and are sending someone out, but I want to make sure I've got the networking down.

Currently the AE is in bridge mode, but I wonder if there's a better way? Thoughts? I also have the Uverse TV boxes and wireless TV receiver sending unit plugged into the Uverse box, but those still seem to work fine even when the Internet is not.



ahughes03
May 8, 2013, 05:43 PM
Look into setting your UVerse router up to allow DMZplus mode to your Extreme. I'm not sure how this option would behave with your tv boxes (as I only use uverse for internet)

Usually, your router's ip should be 192.168.1.254

Go to settings->firewall->applications/pinholes/dmz

Select your airport as the target computer in part 1, select DMZplus in part 2, and click save. You might need to check settings->LAN->IP address allocation to make sure 1) firewall is disabled, 2) address assignment is public, and 3) wan ip is router wan ip.

Then set your extreme to handle DHCP and NAT. I would also recommend creating DHCP reservations for all of your hard-wired and "permanent" devices, as then you will always knew exactly what device is using what IP address. With DHCP and NAT running through your extreme, you have also automatically enabled a firewall, so be sure and set up port-forwarding as needed. I've found this to be way more reliable in terms of running a stable, robust network. Also will allow "n" speeds (uverse router limited to g), and 5Ghz (if you have an extreme capable of dual band 2.4/5). Make sure you turn off your uverse router's wireless, and reconnect all devices to your extreme.

britboyj
May 9, 2013, 09:03 AM
Go to settings->firewall->applications/pinholes/dmz

Select your airport as the target computer in part 1, select DMZplus in part 2, and click save. You might need to check settings->LAN->IP address allocation to make sure 1) firewall is disabled, 2) address assignment is public, and 3) wan ip is router wan ip.


Thanks! This seems to have fixed it. All seems well so far! We'll see how that stands up as I plug in more and more devices into the Netgear switch... The Xbox still reports it's a moderate NAT, but hopefully that changes overtime since that's an average.

Apparently you can also reboot the Nest without resetting anything, which also seemed to help.

ahughes03
May 9, 2013, 01:22 PM
Don't have an Xbox, so not too sure which direction you want to move from "moderate." If you want to move towards open, (I'm assuming this will allow more flexibility with regards to connecting to game servers) you probably just need to open the ports...

First, in your Airport Utility, under the Network tab, ensure the Enable NAT Port Mapping button is selected. If that's not enough, forward the ports you need opened:

1) Ensure you reserved an IP for the Xbox
2) On the same Network tab, click the plus sign on port settings, name it something (Xbox)
3) Enter the following public UDP ports (5060, 5061, 3074) separated by commas
4) In the Private IP address, enter the reserved IP for your xbox
5) Enter the same UDP ports in the private UDP line

Save everything, and you should be good to go. I got the UDP ports from a google search, so there may be others...