PDA

View Full Version : Constant PowerMac G5 crashes...Firefox/Camino related?


dkeninitz
Oct 28, 2005, 05:42 PM
i have a two-month old PowerMac G5, dual 2ghz that is crashing several times each day. I've just begun paying closer attention to what I'm doing when it happens, but as far as I can tell (I don't remember the first couple of crashes), it always happens when I'm surfing the Internet, and -- I think, but am not certain -- only when I go to a site I haven't visited before (but not every new site, it's unpredictable). When it happens, my screen darkens slightly and I get an error message telling me that OS X has quit unexpectedly and that I need to shut down my machine using the power button and then restart it.

I believe this began happening when I switched to the Firefox 1.5 beta. As a test, I deleted this version and loaded build 1.07, but I soon experienced another crash. Then I tried the 1.01 version of Camino, but within a day or so I had another crash. Then I tried build .84 of Camino, eventual crash again. So far it hasn't happened while using Safari, but that could just be because I haven't used Safari since I got this machine, that is until the last couple days in an effort to see if the problem is tied to Firefox or Camino versus something else, like hardware.

I bought the machine direct from Apple with 1 gig of memory, but immediately added 2 gigs that I got from Crucial (before I even booted it the first time). I thought maybe it could be bad memory, but: a) why was I able to go more than a month with no crashes, and b:) why would a browser be more memory intensive than using Photoshop, Final Cut or Logic, which I do every day, with tons of stuff open, rendering, etc. As best I can tell, I haven't had any crashes except when browsing the internet.

I hate Safari, so I'm almost hoping it's not Firefox or Camino, 'cuz I definitely don't want to switch to Safari.

Has anyone else experienced this problem? Thanks for any help.

FFTT
Oct 29, 2005, 02:19 AM
I get the feeling that you've got something else dragging down your system OR you've inadvertently
moved the wrong file from where it belongs.

You should check your activity monitor utility to see
what is running when this happens.

Any time you install or remove an application, you should also repair permissions.

If you've kept regular back-ups, then it may be best to save all your important data and run a fresh OS install.

But before you go that far, install your OS CD and
use the disk repair utility to check your drive
and boot volume.
Also run your Hardware Test CD.

In any event, I think your troubles are software related or the result of Pilot Error.

dkeninitz
Oct 29, 2005, 09:53 AM
Thanks for the suggestions...the only thing you mention that I haven't tried is the Apple hardware test, which I'm going to do today. I've repaired permissions repeatedly, run Disk Utility, cleaned my caches and logs, rebuilt launch services, etc. -- over and over -- rebooting each time, but all to no avail. From searching some other threads here and on other sites, I realize that what I'm getting are kernel panics. Opinion seems to divided as to whether these are more often related to software problems or hardware issues. Apple has a Knowledge Base article stating that software usually is the culprit, but most of the forum threads I've found suggest hardware, specifically memory. So I'm going to run the hardware test and start swapping out memory.