PDA

View Full Version : Problem with "reopen windows when logging back in" in 10.8.4?




adnbek
May 21, 2013, 05:45 PM
Anybody else having problems with this feature every since the 10.8.4 update? With 3 and below, I can be sure that when I leave it unchecked, I get a clean start with no apps running. Ever since the 4 update, I occasionally get applications launching up again even though I've left the box unchecked.



Krazy Bill
May 21, 2013, 09:17 PM
Anybody else having problems with this feature every since the 10.8.4 update? With 3 and below, I can be sure that when I leave it unchecked, I get a clean start with no apps running. Ever since the 4 update, I occasionally get applications launching up again even though I've left the box unchecked.Heh. That was a problem with with 10.8.0 and 10.8.1 I believe. Took them forever to fix it.

So... it's back, huh?

w0lf
May 21, 2013, 10:45 PM
Anybody else having problems with this feature every since the 10.8.4 update? With 3 and below, I can be sure that when I leave it unchecked, I get a clean start with no apps running. Ever since the 4 update, I occasionally get applications launching up again even though I've left the box unchecked.

Have you tried shutting down with the option checked and then unchecking it again the next time you shutdown.

I had this issue before and that fixed it for me.

adnbek
May 22, 2013, 06:42 AM
Have you tried shutting down with the option checked and then unchecking it again the next time you shutdown.

I had this issue before and that fixed it for me.

Of course. I already came up with that fix. And it works temporarily. But the problem comes back seemingly at random.

Krazy Bill
May 22, 2013, 04:26 PM
But the problem comes back seemingly at random.

Go to this folder:

1.) You/Library/Saved Application State/
2.) Delete everything inside it.
3.) "Get info" on the Saved Application State folder
4.) Change the permissions of the folder to "Read Only".

Unless 10.8.4 has done something differently OSX won't be able to write to it thereby neutering the Resume feature. I've been using this tweak since Lion.

adnbek
May 22, 2013, 04:44 PM
Go to this folder:

1.) You/Library/Saved Application State/
2.) Delete everything inside it.
3.) "Get info" on the Saved Application State folder
4.) Change the permissions of the folder to "Read Only".

Unless 10.8.4 has done something differently OSX won't be able to write to it thereby neutering the Resume feature. I've been using this tweak since Lion.

But I don't want to stop the resume feature. I actually like it. I just want that damn checkbox to work properly. :p

HectorCC
Jul 2, 2013, 01:04 PM
Hi, I have the same problem for over a year now. But it only happens on network users. I am running 10.8.4 on server and clients. I have done fresh installs of everything and created new test users and it still happens. I have tried setting application state folder to read only and nothing works. It may work for a few logins and then stops working for a few and then back again. I have tried it with a fresh install and no other apps installed to rule out other software as being the problem. Does anyone have any other idea on what to try next? It is very frustrating and even locks up mail and computer for a few seconds before I can use it when all the apps try to reopen.