View Full Version : Disable Mail.app message "cannot send message"

May 28, 2013, 05:29 AM

I'm working offline from time to time, but Mail.app keeps generating these annoying messages saying that he "cannot send message" and that "the server cannot be contacted", after trying to send alert messages (generated by Calendar.app)

Well I know that the server cannot be contacted.. that's because I'm not connected, because I don't have an internet connection.

How can I disable these messages when I'm working offline? Quitting the Calendar and Mail.app does not work. Processes are working in the background I suppose. And choosing the "Try Later" option just suppresses the message for a while.

What can I do?


May 28, 2013, 09:44 AM
How about "Mail -> Mailbox -> Take All Accounts Offline"?

May 29, 2013, 03:46 AM
How about "Mail -> Mailbox -> Take All Accounts Offline"?

I tried it, but it seems that the background Calendar Agent is the process that keeps restarting Mail.app to send the alert message.

Maybe it's possible to script the killing of the Calendar Agent? Any idea how I could do that? I'm not really familiar with scripting in OSX.


May 29, 2013, 08:50 AM
You seem to have Calendar events that send out emails. I did not get this before. I don't have any such events, I get only notifications right on the screen.

You could experiment with killing the CalendarAgent process through Activity Monitor (that is an Apple program in your Utilities folder). It might or might not start itself right away and will latest be back after the next restart.