PDA

View Full Version : Permissions Fix




nikomoja
Jun 1, 2013, 01:12 AM
Dear All,

I am new to the forum so appreciate your help.

I seem to have (ignorantly) changed the permissions for my Macintosh HD. When I did this, the computer froze (spinning ball) while I was running a text app so eventually I shut it down. On attempting to reboot, I have since not been able to access the Admin screen and the start-up freezes on the Apple Icon on grey background (mouse pointer is maneuverable).

I seem to have tried every option: Running Disk Utility in OSX recovery mode: verifying and repairing disk and permissions for Macintosh HD to no avail. I have tried Safe Boot (Power + Command + Shift) and that ran half way then failed: back to icon and grey background. Finally I have tried running Single User mode and running file system check with: fsck -fy command. Result:

**blah blah blah
** The volume Macintosh HD appears to be OK.
*****The volume was modified*****

I ran fsck -fy again and the "The volume was modified" disapeared so I Rebooted but same problem persists. Start-up freezes on the Apple Icon. :(

Please help! I have not backup my files yet so I am weary to re-install Mountain Lion. also I am currently away from home with terrible internet connection and in urgent need of my laptop for work purposes.:o

I am using a Macbook Pro retina running OSX Mountain Lion v.10.8 (latest).

Appreciate in advance all help and any advice.

Thanks,

Nko



justperry
Jun 1, 2013, 01:16 AM
I answered your question here:

http://forums.macrumors.com/showthread.php?p=17338567#post17338567

Edit: I Edited a bit in that post.


Now, I have to go so if that did not do the job do the following, but first:

*WARNING*WARNING* This will set all Folder and File permissions to Read/Write for everybody, get your Data of to an external, reinstall the OS and import your Data again.


The procedure is:

Boot in Single User Mode, then type

fsck -y
mount -uw /
chmod -R ugo+rwx /

It will take a time to set all permissions, wait it out until the cursor returns.