PDA

View Full Version : What's the oldest version of OS X you still run Xcode 4 on?




ArtOfWarfare
Jun 5, 2013, 12:13 PM
I'm putting together an Xcode 4 plugin and I'm wondering which OS X version I should make be the minimum required. I was hoping to have it be Snow Leopard (same as Xcode 4), but I'm finding some of the tasks I want to do (like parsing code using NSRegularExpressions) require Lion... I'm wondering whether it's worth my effort to find a way around this or not.

So, what version of OS X are you using Xcode 4 with? If no one is using Xcode 4 under Snow Leopard, there's no reason for me to have my plugin support it.

Edit:

There's a poll on this topic if you're viewing this on the full website... The mobile version of the forums seems to omit that.



Madd the Sane
Jun 12, 2013, 12:20 PM
To my knowledge, Xcode 4.2 runs on Snow Leopard, and Xcode 4.6 runs on the lions.

jkcerda
Jun 17, 2013, 01:08 AM
Is there a way to get Xcode 4.2?

PatrickCocoa
Jun 17, 2013, 09:50 AM
As a developer (or any business person) you are hiring your customers.

The naive approach is to get as many customers as possible. Because more money. But a customer has costs, both in terms of money and aggravation.

You may want to deliberately cut out the Snow Leopard users and develop only for Mountain Lion (+ Mavericks). Not because Snow Leopard users are bad people (I have no information on that topic), but because they may be more aggravation and development cost that they're worth.

Sez Mountain Lion user.

gnasher729
Jun 17, 2013, 10:28 AM
Is there a way to get Xcode 4.2?

At developer.apple.com if you look hard enough in their "downloads" section.

jkcerda
Jun 17, 2013, 10:47 AM
At developer.apple.com if you look hard enough in their "downloads" section.

been looking for a bit, I cant find the links anymore
found & downloading 3.2.6 & IOS SDK 4.3

ArtOfWarfare
Jun 17, 2013, 11:55 AM
been looking for a bit, I cant find the links anymore
found & downloading 3.2.6 & IOS SDK 4.3

I see Xcode 4.2.1 for Lion and Xcode 3.2.6 for Snow Leopard... I don't see Xcode 4.2 for Snow Leopard anymore... but if you download Xcode 3.2.6 it comes with iOS SDK 4.3, so at least that's half of what you want. (Why do you want that anyways? As of just 9 days ago, iOS 6 is on 92.6% of devices, iOS 5 is on 5.5%, and iOS 4 is on 1.7%. That number shrinks everyday - I'd say it's pointless if you're just beginning to develop your app to even think about iOS 5, nevermind 4.) [Source (http://chitika.com/ios-version-distribution-Q2-update)]

jkcerda
Jun 17, 2013, 12:10 PM
I see Xcode 4.2.1 for Lion and Xcode 3.2.6 for Snow Leopard... I don't see Xcode 4.2 for Snow Leopard anymore... but if you download Xcode 3.2.6 it comes with iOS SDK 4.3, so at least that's half of what you want. (Why do you want that anyways? As of just 9 days ago, iOS 6 is on 92.6% of devices, iOS 5 is on 5.5%, and iOS 4 is on 1.7%. That number shrinks everyday - I'd say it's pointless if you're just beginning to develop your app to even think about iOS 5, nevermind 4.) [Source (http://chitika.com/ios-version-distribution-Q2-update)]

just trying to learn "X"code, I have an older machine that will not support Lion, figured it's the best way to get your feet "wet" on programming W/O buying a nice MBP, i'm coming in from Windows & I already have a decent laptop, the money is simply not there to buy a MBP at this time.

Madd the Sane
Jun 17, 2013, 06:15 PM
Xcode 4.2 for Snow Leopard was on the Mac App Store for $5.00. Apple may have removed it from the the store directory. I'll see if I can get a link.

Nope, you would have had already purchased it to download it. Sorry.