PDA

View Full Version : Action Folder in /Volumes/




DKnow75
Jun 9, 2013, 08:06 AM
Hi folks,

I'm trying to implement the "Automating Backup of Flash Drives (http://www.cneophytou.com/2007/03/06/automating-backup-of-flash-drives/)" on my Mac Mini i5 with Mac OS X 10.7.5. But, when I run it, it gives an error like "Can't get every file".

If I understood it well, the code should create a list of every item on the folder /Volumes/ in order to test later if some of these items has a file rsync.scpt to execute the backup.

I simplified the code to test just this part with some variations but I didn't succeed.

on adding folder items to this_folder after receiving these_volumes
tell application "Finder"
try
set the volume_list to every file of this_folder as list
display dialog volume_list as text
display dialog number of items in volume_list as text
display dialog this_folder as text

set the volume_list to every folder of this_folder
display dialog volume_list as text
display dialog number of items in volume_list as text
display dialog this_folder as text

set this_item to the original item of item 1 of volume_list
display dialog this_item as text
set this_item to the original item of item 2 of volume_list
display dialog this_item as text

end try
end tell
end adding folder items to

Do you have any suggestion to make this part of the code to work properly?



kryten2
Jun 9, 2013, 02:09 PM
Why not use the script from the link? What do you mean with when I run it?
It is not meant to be run manually but to be attached to a folder.
If you attached this folder action script to the /Volumes folder it gets triggered when items are added to the /Volumes folder like when plugging in a Flash drive. Please post the entire error message.

DKnow75
Jun 9, 2013, 03:02 PM
Why not use the script from the link? What do you mean with when I run it?


I used the script from the link and I followed the instructions to use it (that's what I mean by 'run it'). I set the action script for the folder Volumes to execute the auto_backup script as mentioned on the link. But when I added an USB stick it did nothing. It didn't copy the USB stick's content to my HD as I specified on rsync.scpt. It didn't show any error message also.

As the rsync.app is working properly (I test it on my USB stick), I started to debug the auto_backup script to see what happened. At the debugging the script shown the message 'Can't get every file' for the variable 'volume_list' on the line:
set the volume_list to every file of this_folder

That's why I tried to simplify the script to test this line and other variations for it to see if it works.

kryten2
Jun 9, 2013, 03:29 PM
Describe your debugging process or better post a screenshot of it.

DKnow75
Jun 12, 2013, 04:08 PM
Here there is an image of the debugging process for the auto_backup.scpt...

http://img42.imageshack.us/img42/5161/debuggingautobackupscri.gif (http://imageshack.us/photo/my-images/42/debuggingautobackupscri.gif/)

Uploaded with ImageShack.us (http://imageshack.us)

DKnow75
Jun 15, 2013, 07:12 AM
Thats intrigues me...