PDA

View Full Version : Remove menu bar from second monitor?


sgarrand
Jun 11, 2013, 09:07 PM
When I go full screen on my second monitor the menu bar is always present. I'm watching MLB.tv in full screen but that darn menu bar is still there. Any ideas on how to remove it or auto hide it? Thanks.

Edit: Okay, Safari will show full screen video without the menu bar, Chrome Canary will not. The question remains though, I'd love to not show a menu bar on the second monitor.

Scott

Galaxas0
Jun 11, 2013, 09:33 PM
I'd submit a ticket for this feature.

hobbyrennfahrer
Jun 14, 2013, 11:19 AM
Any fix for this?
How they can be so stupid and let the menu bar on the second screen always on top of everything? :mad::mad::mad:

DJLC
Jun 14, 2013, 11:20 AM
Any fix for this?
How they can be so stupid and let the menu bar on the second screen always on top of everything? :mad::mad::mad:

Wait for them to actually release the OS? It sounds like you're expecting perfection from a beta.

hobbyrennfahrer
Jun 14, 2013, 11:22 AM
That "bug" is absolutely hilarious. Beta or not.

iRebound
Jul 24, 2013, 07:40 PM
I'm having the same issue here with Plex. I have a TV hooked up as the 2nd monitor.

mikecwest
Jul 24, 2013, 07:51 PM
That "bug" is absolutely hilarious. Beta or not.

Thats not a bug, its a new feature. In my opinion, a very welcome one. It goes away for me if I select Full Screen from the menubar... Its a pain in the rear if you are using two displays to have to move the cursor 27 inches to the left (Thundebolt display), then 15 more inches to the left (laptop screen) to reach the File Menu.

I can not even imagine the frustration of someone using three thunderbolt displays on a mac pro, and NOT having easy menu bar access.

Kinsella
Jul 25, 2013, 07:26 AM
Thats not a bug, its a new feature. In my opinion, a very welcome one. It goes away for me if I select Full Screen from the menubar... Its a pain in the rear if you are using two displays to have to move the cursor 27 inches to the left (Thundebolt display), then 15 more inches to the left (laptop screen) to reach the File Menu.

I can not even imagine the frustration of someone using three thunderbolt displays on a mac pro, and NOT having easy menu bar access.

I fully agree. Having to move the cursor from my external monitor to the laptop screen to access the menu bar is quite annoying, and I'm looking forward to having the menu bar available on all screens.

mikecwest
Jul 26, 2013, 01:01 AM
I fully agree. Having to move the cursor from my external monitor to the laptop screen to access the menu bar is quite annoying, and I'm looking forward to having the menu bar available on all screens.

I think it would also be nice to give users a choice, a simple check box in the displays preference panel would be nice.

DiscardedPacket
Jul 26, 2013, 07:50 AM
I did a powerpoint presentation recently and the menu bar was visible on the projector when powerpoint was presenting.

pretty annoying. But - "its beta".

jhfenton
Jul 26, 2013, 08:18 AM
It won't be a problem eventually. The menu bar on secondary monitors can be hidden by aware programs. It just has to be programmed for. Give developers time to get their programs updated for Mavericks.

rayhigh
Jul 26, 2013, 10:20 AM
Running programs in fullscreen on the secondary monitor hides it for me, at least with the program that I tried it with, VLC. I did have to reenable the 'use native Lion fullscreen mode" checkbox in VLC.

Packdude
Jul 26, 2013, 04:26 PM
In VMware Fusion 5, the View is set to Full Screen, Hide Menu Bar in full screen is checked as well. I've used MenuEverywhere for a long time, so I'm used to having a menu bar on the second display. However, it was set to 'auto hide' when I wasn't using it. I'm hoping that they fix this when the OS is officially released.

bedifferent
Jul 27, 2013, 12:56 PM
Thats not a bug, its a new feature. In my opinion, a very welcome one. It goes away for me if I select Full Screen from the menubar... Its a pain in the rear if you are using two displays to have to move the cursor 27 inches to the left (Thundebolt display), then 15 more inches to the left (laptop screen) to reach the File Menu.

I can not even imagine the frustration of someone using three thunderbolt displays on a mac pro, and NOT having easy menu bar access.

You found him! 3 27" Cinema Displays on my 12-Core 5,1. It's fun! :)

In all seriousness, welcome the new support. No need for "SecondBar" (which only supported an extra display). The "Dock" needs tweaking, it's sometimes touchy appearing on secondary displays. Add options in "System Preferences" to turn on/off additional MenuBars, custom transparency for each MenuBar, "Dock" appearance (bottom for main, left for left display, right for right, so forth). File "UI" bugs, the more filed the better the odds.

One "bug" I've had since 10.5 is the **** color. Why silver with tiny little indicators?! Until 10.8, the first thing I'd do was replace the dock png's with glossy or jet black. Much easier to see what's running, etc. Now it's "adaptive."

varyform
Oct 5, 2013, 12:00 PM
The "solution" to this issue is to uncheck "Displays have separate Spaces" under System Preferences -> Mission Control.

jhfenton
Oct 5, 2013, 08:44 PM
Running programs in fullscreen on the secondary monitor hides it for me, at least with the program that I tried it with, VLC. I did have to reenable the 'use native Lion fullscreen mode" checkbox in VLC.
Yes. The problems is with programs that don't use the native fullscreen mode. If they manage fullscreen themselves, they don't know to hide the menubar on a secondary display because in the past there wasn't a menu bar on secondary displays. And a lot of programs did manage fullscreen themselves because Mountain Lion fullscreen mode was terrible (with linen on all the other displays).

This problem will go away in well-behaved programs once they're updated to hide the menu bar on secondary displays or to use the now-more-useful native Mavericks fullscreen mode.

The "solution" to this issue is to uncheck "Displays have separate Spaces" under System Preferences -> Mission Control.

Of course, then you lose the Mavericks improvements in handling multiple displays. :)

John

varyform
Oct 6, 2013, 06:57 PM
Of course, then you lose the Mavericks improvements in handling multiple displays. :)


Well, You will still be able to have full screen app on each display.

jhfenton
Oct 6, 2013, 07:03 PM
Well, You will still be able to have full screen app on each display.

OK. So you lose half of the Mavericks multi-monitor improvements. :)

I like swiping individual spaces on separate monitors too much.

jdaniel
Oct 8, 2013, 01:49 AM
The "solution" to this issue is to uncheck "Displays have separate Spaces" under System Preferences -> Mission Control.


THANKS.. lots of other people babbling away not answering the question... but THANK YOU :)

ima747
Oct 16, 2013, 10:28 AM
The "solution" to this issue is to uncheck "Displays have separate Spaces" under System Preferences -> Mission Control.

Thank you for this! was driving me crazy.

The new system is going to be a god send for some users, but for people like my with a very specific work flow it would absolutely destroy my productivity.

And regarding how far you have to move a cursor, I have 3x27" wqhd screens and a 21", the reason I need so much space is so I can organize lots of things at once, since I'm organizing it all I put things that need the menu bar (which is actually rare, especially if you ever use keyboard shortcuts...) near the menu bar, and other stuff (finder windows for example) very far away from the menu bar. If you find you're going from one extreme to a menu bar on a regular basis your work flow is probably not very streamlined (mouse time is not typically as productive as keyboard time, depends on what you're doing of course). Just my 2c. I don't begrudge anyone the new system, I can see how it might be amazing, but not for me so I'm SO happy they didn't forget a check box to turn it OFF (i.e. the reason I skipped Lion entirely, you couldn't turn off most of the new stuff that caused me problems in my work flow until Mountain Lion.)

allan53
Oct 24, 2013, 04:47 PM
The "solution" to this issue is to uncheck "Displays have separate Spaces" under System Preferences -> Mission Control.

That doesn't help me. I use PS. I have the images on the left monitor and all my tools on the right monitor. The menu bar is on the left monitor so I have to move mouse from checking a tool on the right monitor all the way across to the menubar on the left monitor.

Effilly
Oct 25, 2013, 04:17 AM
Thats not a bug, its a new feature. In my opinion, a very welcome one. It goes away for me if I select Full Screen from the menubar... Its a pain in the rear if you are using two displays to have to move the cursor 27 inches to the left (Thundebolt display), then 15 more inches to the left (laptop screen) to reach the File Menu.

I can not even imagine the frustration of someone using three thunderbolt displays on a mac pro, and NOT having easy menu bar access.

I, and I only can decide in what way I prefer the set-up of my monitors.
So this "option" should stay an option. Not something I can't get around.

jfrye
Oct 25, 2013, 06:48 PM
Wish I had known about this 'improvement' before upgrading my OS. I use an iMac at a church with multiple big screen displays on stage and the toolbar is showing at the top of all of them. I do not have time to wait until program developers fix this, if they ever do.

jfrye
Oct 25, 2013, 07:02 PM
I came across this for my ProPresenter program which seems like it should address all the other known issues with it now:

"If you have already downloaded Mavericks and are having issues with your output not going to the correct screen or your menu bar appearing over your output, open Apple System Preferences, select Mission Control, and uncheck "Displays Have Separate Spaces". You will need to logout for the change to take effect. This resolves all currently known issues with ProPresenter 5 in Mavericks."

This is from:
http://forums.renewedvision.com/showthread.php/14964-OS-X-10-9-(Mavericks)-Information-and-Known-Issues

I have not tested this yet myself though.

DOWNSIDEUP
Oct 29, 2013, 01:26 PM
When I fullscreen an app on my secondary display, the menu bar hides, but menu bar background remains and the app doesn't really stretch fullscreen.

To fix this, quit the app completely and reopen it from your secondary display. Then everything should be fine.

Just thought I'd share.

andyging3
Oct 30, 2013, 06:36 AM
The "solution" to this issue is to uncheck "Displays have separate Spaces" under System Preferences -> Mission Control.

I use Proselect viewing software and this solved the issue. Many thanks.:)

xeronozoio
Dec 2, 2013, 04:51 PM
Thats not a bug, its a new feature. In my opinion, a very welcome one. It goes away for me if I select Full Screen from the menubar... Its a pain in the rear if you are using two displays to have to move the cursor 27 inches to the left (Thundebolt display), then 15 more inches to the left (laptop screen) to reach the File Menu.

I can not even imagine the frustration of someone using three thunderbolt displays on a mac pro, and NOT having easy menu bar access.


Selecting Full screen from the menubar made the damn bar go away for good! thanks again.

adamj575
Dec 3, 2013, 11:12 AM
ive been trying to figure this out too...ill give it a shot!

Ardmanz
Dec 23, 2013, 07:34 AM
Has anyone found a solution to this? I've tried everything suggested in this thread to no avail.

Is this a Mavericks or a VLC issue?

merckens
Feb 10, 2014, 11:10 AM
When I go full screen on my second monitor the menu bar is always present. I'm watching MLB.tv in full screen but that darn menu bar is still there. Any ideas on how to remove it or auto hide it? Thanks.

Edit: Okay, Safari will show full screen video without the menu bar, Chrome Canary will not. The question remains though, I'd love to not show a menu bar on the second monitor.

Scott

For anyone looking for a solution to the original problem or one like it, the answer has already been given by DOWNSIDEUP:

When I fullscreen an app on my secondary display, the menu bar hides, but menu bar background remains and the app doesn't really stretch fullscreen.

To fix this, quit the app completely and reopen it from your secondary display. Then everything should be fine.

Just thought I'd share.

So, for example, if you open a movie in VLC and drag it over to your secondary monitor or (as in the case of the original post) you open an MLB.tv game and drag it over, the translucent menu bar will *always* show on the secondary monitor. The external monitor is a separate space (unless you've deselected that option in System Preferences, which is kind of a silly thing to do), so if you drag a window over to the second screen, the application is actually running out of your machine's space and not from the secondary monitor's space. So in the eyes of the external monitor, the focus is still on your machine's space when you're running a dragged VLC or browser window in full screen on the secondary monitor. So it displays that obnoxious translucent menu bar.

So long story short (too late!), literally all you need to do is close the application, put the focus on your secondary monitor's space (by switching to an app running in that space or using the dock on that space or whatever), and then reopen the application from within the secondary monitor's space. Now when you go fullscreen, the menu bar won't be there, because the focus of the application is in the space it's running fullscreen in.

(Side note: When Scott says, "Okay, Safari will show full screen video without the menu bar, Chrome Canary will not", I guarantee he opened Safari from within the secondary monitor's space, but the Chrome process was the same one he initially started on his machine's space. I would bet the farm that if he quit Chrome and reopened it from within the secondary monitor, it would display the MLB.tv game without the menu bar.)