PDA

View Full Version : Mavericks: Upon booting, keeps going back to login screen / logging user out


Steveomi
Jun 15, 2013, 01:04 AM
Hi guys

I've installed Mavericks today on my 2009 iMac and ever since it's installed, I'm logging in as usual and then it spends around 30 seconds loading my 'open at login' apps and then it just stops and sends me back to the login screen with the user name and password. Do you have any idea why this might be happening?

It might be a conflict with an app or two, perhaps? If so, how do I go about removing them? I've tried going into Safe Mode but the same thing happens and I've also tried repairing and verifying disks and disk permissions in recovery mode, and I'm out of ideas. Can someone help?

I would really appreciate it.

Thanks
Steve.

charlie0226
Jun 16, 2013, 08:14 AM
I also have this problem with my computer. Read from some other forum, it seems like some problems with screen saver or auto logout under security. Tried to change the setting, but failed to go into the preference setting screen. Anyone can help with this.

zodiakp
Jun 16, 2013, 08:19 AM
I was having the same problem... I kept it that way and the issue got resolved it self.. but I am afraid it may comeback anytime... I am afraid of log off or turn off my MBP. please help

Kevin Paquet
Aug 9, 2013, 11:11 AM
Anyone who was able to resolve this? I'm having the same problem. :mad:

secrgb
Aug 10, 2013, 01:47 PM
Hey,

I seemed to have the same issue. There seems to be a problem with windows server that crashes right after credentials entered.

My solution was to boot into single user mode, erase setup complete file, reboot, create new user and finally complete another update via appstore.

Hope this solves your issues :)

S.

heyadrian
Aug 13, 2013, 10:47 PM
Another way is to reset the NVRam aka (PRAM back in the day).

Turn the MacBOok/iMac/MacPro off.

With +Option+P+R pressed on the builtin (or USB keyboard), press the power button.
Keep holding that lot in until you hear the machine chime a SECOND time

That does reset preferences, but the only reason I assumed this is because of the new scalable power saving features in OSX, I can only assume screensaver prefs etc... are now stored in NVRam.

Mounder
Oct 24, 2013, 09:33 AM
Thanks @heyadrian for the suggestion . . . unfortunately, it did not work. :confused:

capuman
Oct 25, 2013, 06:27 AM
I actually spent 2 hours talking to tech support yesterday.

After i reinstalled Mavericks from recovery nothing changed. I had the same problems.

After 2 PRAM and SMC resets nothing changed.

I still cant login after start up so im still having to leave autologin on. This is really weird because if i put my imac to sleep, when i wake it up i AM able to login!!!!????

So the only time i cant login is if i actually logout and then try to relogin. I found one guy who had the same problem, the exact problem, but he was using a beta version of Mavericks, and this was back in June: http://forums.macrumors.com/showthread.php?t=1600029

deltavee
Oct 25, 2013, 07:00 AM
Anyone who was able to resolve this? I'm having the same problem. :mad:

Yes, I resolved auto-logout by zapping the PRAM as suggested.

MBP Retina 2.6 GHz Intel Core i7