PDA

View Full Version : OSX Server (10.8.3 & 10.8.4) AFP crashes - usually as a result of disk mounting?




OT-Mac
Jul 7, 2013, 07:12 PM
Hi All,

Anyone out there experiencing the same issue - and potentially has a method of resolving this?

Our company OSX file server (10.8.4) is experiencing a very unstable AFP environment, where AFP crashes (while SMB continues to work). The log file shows repeated lines similar to:

[Date] [Servername] AppleFileServer[48642] <Info>: TCP Listener returned error on accept
[Date] [Servername] AppleFileServer[48642] <Info>: TCP Listener returned error on accept
etc...

This is happening multiple times a week. Sometimes this appears to be entirely random, but on other occasions the following two "precursor" events seem to trigger such events:

- Mounting/Unmounting a disk (either physical eg. Firewire or virtual eg. .DMG).
- Accessing server via Remote Desktop (via VPN?)

This has been the case both with 10.8.3 and 10.8.4 (which we hoped would resolve this).

More info about our setup:

The Mac server is a 2012(?) MacPro 12 core. It has 64GB RAM and is not in need of any more. The file shares are on a separate Pegasus RAID connected via fibre channel.

It is set up in the usual AD-OD relationship with a pair of AD servers (one virtual on the MacPro via VMWare and one on a seperate MacMini).

In all cases, the SMB file sharing is unaffected, but the AFP is dropping off until we manually restart the service by entering the following into Terminal:

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.AppleFileServer.plist
sudo serveradmin start afp

Anyone out there who has an idea of what might be going on? Happy for any suggestions! This is causing us a lot of grief.

Thanks!



jfwx5
Jul 7, 2013, 09:24 PM
Hi,

Had the same problem. Mine was a result of the DNS Machine A record not being set up properly. See http://www.mountainlionserver.com/dns/. It's has been working great since the change was setup.

HTH