PDA

View Full Version : What plugins have you found to be incompatible with Logic X?




CausticPuppy
Jul 17, 2013, 09:08 PM
Kontakt 5 works fine so my EWQL libraries will work.


Aria (latest version) does not show up. It's advertised as 64-bit "compatible" but does not appear to actually be fully 64-bit, so your GPO4, Instant Orchestra, Jazz/Big Band etc. won't work yet.

Hopefully it'll be updated soon.... :mad:

UPDATE: Aria does work. Something was messed up in the upgrade process that prevented the AU plugin from being updated unless the old file was deleted first.

Here are the steps I followed to get it to work:

1) Reinstall the latest download version of GPO4 (note that this still includes an OLD version of ARIA)
2) Remove (or rename) the ARIA plugin file in /Library/Audio/Plug-Ins/Components/
3) Install the latest version of ARIA player- you should see a new file created in that directory


May have just been an issue on my system but after the above steps, ARIA shows and performs just fine with the GPO4 library in Logic X.



Diastro
Jul 18, 2013, 01:59 AM
Obviously anything you needed the 32-bit bridge for doesn't work. Luckily anything from Native Instruments works perfect, as it's all native 64 bit. I did have some trouble with FabFilter plugins, they are a bit glitchy in LPX for some reason. Wouldn't load properly when opening L9 projects.

CausticPuppy
Jul 19, 2013, 07:47 AM
Fixed! See first post.

Icaras
Jul 26, 2013, 10:08 PM
Luckily anything from Native Instruments works perfect, as it's all native 64 bit.

That's great to hear. Thanks for sharing. Will be finally getting LPX next week and I've already got a bunch of NI libraries. :)