PDA

View Full Version : VLC Playlist won't work?!




doubledee
Jul 26, 2013, 12:17 AM
I just installed VLC media player v2.0.7 on my new cMBP and cannot get my newly created Playlist to work when I launch VLC... :mad:

When I open VLC, I see a yellow triangle next to my Playlist and the following error window...


Errors and Warnings

Your input can't be opened

VLC is unable to open the MRL '/Users/user1/Documents/_RADIO_CAPTURE/+TEMPLATES_2013-07-25/__MyVLCPlaylist_2013-07-25.m3u'

(I can't technically see the bolded part, but I assume it is there?!)


If I look at the Error Log I get this...


main debug: using interface module "macosx"
main debug: TIMER module_need() : 66.736 ms - Total 66.736 ms / 1 intvls (Avg 66.736 ms)
main debug: playlist threads correctly activated
main debug: rebuilding array of current - root Playlist
main debug: rebuild done - 1 items, index -1
macosx debug: using future AR cookies
main debug: looking for services probe module: 5 candidates
main debug: no services probe module matching "any" could be loaded
main debug: TIMER module_need() : 2.884 ms - Total 2.884 ms / 1 intvls (Avg 2.884 ms)
main debug: looking for extension module: 1 candidate
lua debug: Opening Lua Extension module
lua debug: Trying Lua scripts in /Users/user1/Library/Application Support/org.videolan.vlc/lua/extensions
lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/lua/extensions
lua debug: Trying Lua scripts in /Applications/VLC.app/Contents/MacOS/share/share/lua/extensions
main debug: using extension module "lua"
main debug: TIMER module_need() : 0.186 ms - Total 0.186 ms / 1 intvls (Avg 0.186 ms)
macosx debug: Found 1 capture devices
main debug: processing request item: __MyVLCPlaylist_2013-07-25.m3u, node: Playlist, skip: 0
main debug: resyncing on __MyVLCPlaylist_2013-07-25.m3u
main debug: __MyVLCPlaylist_2013-07-25.m3u is at 0
main debug: starting playback of the new playlist item
main debug: resyncing on __MyVLCPlaylist_2013-07-25.m3u
main debug: __MyVLCPlaylist_2013-07-25.m3u is at 0
main debug: creating new input thread
main debug: Creating an input for '__MyVLCPlaylist_2013-07-25.m3u'
main debug: using timeshift granularity of 50 MiB, in path '/tmp'
main debug: `/Users/user1/Documents/_RADIO_CAPTURE/+TEMPLATES_2013-07-25/__MyVLCPlaylist_2013-07-25.m3u' gives access `' demux `Users/user1/Documents/_RADIO_CAPTURE/+TEMPLATES_2013-07-25/__MyVLCPlaylist_2013-07-25.m3u' path `'
main debug: creating demux: access='' demux='Users/user1/Documents/_RADIO_CAPTURE/+TEMPLATES_2013-07-25/__MyVLCPlaylist_2013-07-25.m3u' location='' file='(null)'
main debug: looking for access_demux module: 4 candidates
main debug: no access_demux module matching "any" could be loaded
main debug: TIMER module_need() : 0.722 ms - Total 0.722 ms / 1 intvls (Avg 0.722 ms)
main debug: creating access '' location='', path='(null)'
main debug: looking for access module: 6 candidates
main debug: no access module matching "any" could be loaded
main debug: TIMER module_need() : 1.371 ms - Total 1.371 ms / 1 intvls (Avg 1.371 ms)
main error: open of `/Users/user1/Documents/_RADIO_CAPTURE/+TEMPLATES_2013-07-25/__MyVLCPlaylist_2013-07-25.m3u' failed
main debug: dead input
main debug: changing item without a request (current 0/1)
main debug: nothing to play
main debug: TIMER input launching for '__MyVLCPlaylist_2013-07-25.m3u' : 49.184 ms - Total 49.184 ms / 1 intvls (Avg 49.184 ms)



Under VLC Preferences > Show All > Playlist > Default Stream I have this...


/Users/user1/Documents/_RADIO_CAPTURE/+TEMPLATES_2013-07-25/__MyVLCPlaylist_2013-07-25.m3u



Any idea how to fix this so when I launch VLC and double click on my Playlist, it actually works??? :confused:

Sincerely,


Debbie



SnowLeopard2008
Sep 30, 2013, 08:02 PM
It seems as if VLC can't access the playlist for some reason. Can you delete it and re-add? Also, are the songs that your playlist references in the same directory as the playlist file?