PDA

View Full Version : Network user login issues




dpaanlka
Jul 31, 2013, 10:37 AM
Hello everyone

I've been trying to move all our users at our office to be network users where anybody can just sit down and login at any workstation instead of being tied to specific workstations. I have Mountain Lion Server and followed a tutorial I found online. I've created test user account on the server. When I sit down at a workstation that I've configured to use the server for network accounts, I can log into the test account, but only when it's set to use "Local Only" as its home folder on the server. If I change to a "Home Folders" share point I created, the login fails with "an error occurred" which is not very informative. I'm not sure where I might be going wrong here. Any ideas?

Thanks! :)



carlosribas
Jul 31, 2013, 11:11 AM
Hello everyone

I've been trying to move all our users at our office to be network users where anybody can just sit down and login at any workstation instead of being tied to specific workstations. I have Mountain Lion Server and followed a tutorial I found online. I've created test user account on the server. When I sit down at a workstation that I've configured to use the server for network accounts, I can log into the test account, but only when it's set to use "Local Only" as its home folder on the server. If I change to a "Home Folders" share point I created, the login fails with "an error occurred" which is not very informative. I'm not sure where I might be going wrong here. Any ideas?

Thanks! :)

I suppose you are using server.app, right? Check the settings of your File Sharing service. You must enable "Allow guest users to access this share" and "Make available for home directory". Hope this help.

dpaanlka
Jul 31, 2013, 11:28 AM
I suppose you are using server.app, right? Check the settings of your File Sharing service. You must enable "Allow guest users to access this share" and "Make available for home directory". Hope this help.

Yes, those are both enabled.

carlosribas
Jul 31, 2013, 01:39 PM
Yes, those are both enabled.
Maybe this video can help you: http://www.youtube.com/watch?v=840dnD3P82s

dpaanlka
Aug 1, 2013, 09:59 AM
Yes, I already am beyond everything in that tutorial. Right now, if I set network users to use "local only" from the server, then they can log in just fine from the workstations. I can see in the users directory that the workstation creates a new home folder for the logged in network user on the local drive.

However if I set the home folder to be on one of the share points, the login fails with the "because an error occurred". I checked the DNS settings on the server and they appear to be correct. I'm not sure where I'm going wrong here, or even what to check.