PDA

View Full Version : Apps that I quit before shutdown magically re-open




dstrozzi
Aug 2, 2013, 09:20 AM
Hi,

I've had this problem persistently on two Macbooks w/ 10.8. I am happily using the machine, and I decide to shut it down. Not sleep - shut down. I quit out of all apps. I then goto shutdown. I don't tell it I want to re-open apps. Which shouldn't matter anyway since none are open.

Later, I reboot. Upon logging in, apps that I had previously shut down open! It's as if the machine is thinking "oh, whatever **** you had running an hour before shutting down needs to be re-opened."

Thoughts?



sonicrobby
Aug 2, 2013, 09:22 AM
Some apps might just be set to open at startup, regardless of its status when shutting down. My iTunes is set up that way. I cant remember where to go to turn it off though.

dstrozzi
Aug 2, 2013, 09:40 AM
Thanks, nice try, but apps I've started for the first time in months do this. It's not an auto-start problem. I suspect the OS has a bug in it....

GGJstudios
Aug 2, 2013, 09:43 AM
Thanks, nice try, but apps I've started for the first time in months do this. It's not an auto-start problem. I suspect the OS has a bug in it....
If it was a bug in the OS, many others would be experiencing the same thing. Does it happen every time you restart or boot up?

You can check the following locations for apps that automatically launch on startup and delete any you don't need/want: System Preferences > Users & Groups > yourusername > Login Items (SL and older: System Preferences > Accounts > yourusername > Login Items) In Finder, click Go > Go to Folder > /Library/LaunchAgents In Finder, click Go > Go to Folder > ~/Library/LaunchAgents In Finder, click Go > Go to Folder > /Library/StartupItems

SR45
Aug 2, 2013, 10:50 AM
With me, I have to Quit the application as shown, in order for it not to return upon boot up, but for some unknown reason a few do. Same with Safari, and some of the other programs or apps. Is this the same with you ?

Weaselboy
Aug 2, 2013, 12:45 PM
Thanks, nice try, but apps I've started for the first time in months do this. It's not an auto-start problem. I suspect the OS has a bug in it....

It is a bug and many users have a problem getting this setting to "stick."

Try this. Shutdown and check the box that you do want apps to restart, then complete the shutdown.

After the restart, do another shutdown and option key click the same checkbox to uncheck it. This should make the uncheck stick.