PDA

View Full Version : Apple TV 3 network problems




DP812
Aug 5, 2013, 07:24 AM
I'm house-sitting for a friend and I brought my MacBook Air and Apple TV 3 intending to watch some movies on Netflix while I'm here. Now, my laptop connects to wifi and the Internet just fine. The problem comes with the Apple TV—it connects to the network, but it absolutely will not connect to the Internet. I checked the settings and under router and DNS address, it just reads N/A. I tried restarting the router, the modem, and the Apple TV, all with no luck. Then I tried resetting the Apple TV hoping that would clear whatever the problem was—still no luck.

But now an even bigger problem has occurred: before the reset, I could at least connect to Home Sharing. But since the reset, the Apple TV will connect to my network, but will not allow me to turn on Home Sharing. It keeps telling me the Apple ID and password is incorrect. I double-checked my password and ID by logging into the iTunes Store from my MacBook and it works without a problem. Then I realized that the Apple TV has no location set for the iTunes Store. I went to try to set one, but because there's no Internet connection, it won't let me set a location.

Does anyone have any idea how I could get the Internet up and running or at the very least turn on Home Sharing?



FreakinEurekan
Aug 5, 2013, 11:05 AM
Your 2nd problem is caused by your first one. You can't turn on home sharing without the ATV authenticating your Apple ID, which requires Internet access.

Troubleshooting steps here:

http://support.apple.com/kb/TS4546

DP812
Aug 5, 2013, 05:08 PM
I know the second problem is related to the first. And like I said, I've tried restarting the aTV and the router, both with no luck. Apple's "support" pages are a total joke when it comes to the aTV, all their advice consists of, "have you restarted the aTV and the router?"

Cinephi1e
Aug 5, 2013, 08:03 PM
What router are you using? If I remember correctly, Apple TV requires some ports to be open. It also will have trouble connecting if you are using VPN. It seems to work best with Apple routers.

FreakinEurekan
Aug 6, 2013, 12:57 PM
I know the second problem is related to the first. And like I said, I've tried restarting the aTV and the router, both with no luck. Apple's "support" pages are a total joke when it comes to the aTV, all their advice consists of, "have you restarted the aTV and the router?"

99% of the time that's enough :)

waw74
Aug 6, 2013, 01:44 PM
make sure the aTV is really connected to the internet.

try re-entering the wi-fi password, sounds like you're not connected.

when i first got mine, i had it hardwired, took me several minutes to figure out my problem. I hadn't gotten the ethernet plug fully seated. I was repeatedly entering my home sharing info, and the aTV kept saying incorrect password, but what it really meant was "I can't connect to apple to check the password"