PDA

View Full Version : MacBook Air 2013 Wifi Problems




james83
Aug 6, 2013, 02:53 PM
Im planning to buy the Air this week but have just heard about all the issues and complaints people are having with the wifi dropping. Seems Apple introduced an update to solve the problem but people are claiming it still hasn't solved it.

I'm gussing this has been discussed to death but can't see any posts on it. Can anyone shed any light on this? Is it a common issue and should I be worried? :confused:



scaredpoet
Aug 6, 2013, 04:28 PM
It's not a common issue anymore, near as I can tell. In any case, you can get your MBA exchange IF you encounter this problem.

Mine's over a month old and it's been in various Wifi hotspots, and I've never had a problem.

climater
Aug 8, 2013, 09:13 PM
I'm having exactly this issue with the new MBA that I picked up today. The issue persists after I installed MacBook Air (Mid 2013) Software Update 1.0. I guess the most sensible action to take is to have it exchanged.

AXs
Aug 8, 2013, 10:02 PM
The only issue is that it is not as fast as it is supposed to be. But if you don't have an AC router at this point, then I think that there is nothing to worry about.

johnjey
Aug 9, 2013, 02:37 PM
Sadly despite Apple fixes on the wi-fi thing...air takes a good 30 Seconds before connecting back to a wi-fi whenever it is woken up from a sleep or even a blacked out screen (as in display monitor of mac is off)

Suraj R.
Aug 9, 2013, 02:47 PM
Sadly despite Apple fixes on the wi-fi thing...air takes a good 30 Seconds before connecting back to a wi-fi whenever it is woken up from a sleep or even a blacked out screen (as in display monitor of mac is off)

I experience this also, but its more like 10 seconds. Not terribly important, just annoying and makes me worry that something is wrong with my computer.

AXs
Aug 9, 2013, 02:56 PM
have you downloaded the latest update fix?

johnjey
Aug 11, 2013, 02:16 PM
have you downloaded the latest update fix?

Yeah updated with the fixes

hockeyfanatic
Aug 11, 2013, 02:18 PM
I only had problems when closing lid or entering screen saver mode.

Installing free app, lock me now, resolved the issue.:)

SteveJobs2.0
Aug 11, 2013, 03:36 PM
I only get an issue with wfi in Windows 7. For some reasons it doesn't see any wireless networks requiring a restart. In Mountain Lion things seem to be working 99% of time.

Lord Xeb
Aug 11, 2013, 09:24 PM
Make sure you run all updates. There is a rare issue with the MBA 2013 models that can cause wifi issues.
http://support.apple.com/kb/TS4611

imjoee
Aug 11, 2013, 11:44 PM
Im planning to buy the Air this week but have just heard about all the issues and complaints people are having with the wifi dropping. Seems Apple introduced an update to solve the problem but people are claiming it still hasn't solved it.

I'm gussing this has been discussed to death but can't see any posts on it. Can anyone shed any light on this? Is it a common issue and should I be worried? :confused:

I picked up a macbook air this week. no wifi problems at all.

climater
Aug 14, 2013, 06:12 PM
I'm having exactly this issue with the new MBA that I picked up today. The issue persists after I installed MacBook Air (Mid 2013) Software Update 1.0. I guess the most sensible action to take is to have it exchanged.

I just returned it for an exchange. I had experienced intermittent Wi-Fi dropping on this MBA. It can reconnect if I turn AirPort off and on again, but drops again soon. Whether this is a MBA issue or a router problem I cannot tell. But a 2011 MBP and a PC have no issue at all with the router. Did anyone have similar symptoms?

Ronnoco
Aug 14, 2013, 06:43 PM
Two week old 2013 13" i7 MBA, no wifi problems.

Hello...
Aug 14, 2013, 08:01 PM
Mine was delivered today and no wifi problems at all.

Tarrou8
Aug 14, 2013, 09:40 PM
Never had a single drop in two months.

bellang
Aug 15, 2013, 05:03 AM
I just returned it for an exchange. I had experienced intermittent Wi-Fi dropping on this MBA. It can reconnect if I turn AirPort off and on again, but drops again soon. Whether this is a MBA issue or a router problem I cannot tell. But a 2011 MBP and a PC have no issue at all with the router. Did anyone have similar symptoms?

Exactly the same. If I run a ping of say google.com, every 5-10 seconds there'll be a huge delay (up to 2 seconds). Happens on 2.4 & 5ghz wireless, and not on any other wireless devices in house incl macbook pro. Also should add it happens in bootcamp as well as mac os. Guessing its hardware so taking it in on Saturday to see what they say....

climater
Aug 15, 2013, 01:04 PM
Exactly the same. If I run a ping of say google.com, every 5-10 seconds there'll be a huge delay (up to 2 seconds). Happens on 2.4 & 5ghz wireless, and not on any other wireless devices in house incl macbook pro. Also should add it happens in bootcamp as well as mac os. Guessing its hardware so taking it in on Saturday to see what they say....

Please do report what they would say if you don't mind. I was simply advised in an apple store to make an exchange. Since mine was a CTO (RAM max'ed to 8GB), I had to return it and reorder online. It does seem to be device-dependent, since the Wi-Fi connection from this MBA had no problem in the apple store (albeit I didn't test it for long).

bellang
Aug 15, 2013, 01:09 PM
Will do. Curious if they'll let me return it as it was CTO as well and is approx one month old. I'm going to take my new time capsule in as well since it's an apple product in case they try to blame the router! (Though it happens with different routers, don't want a delay tactic)

Lara2426
Aug 16, 2013, 07:27 AM
Have had major and serious issues with wifi connectivity, also update of patch to fix problem, can't take it anymore, getting a refund, 3rd MacBook air 2013 in 2 months. Do yourself a favor and get something else!

calvol
Aug 16, 2013, 01:26 PM
Have had major and serious issues with wifi connectivity, also update of patch to fix problem, can't take it anymore, getting a refund, 3rd MacBook air 2013 in 2 months. Do yourself a favor and get something else!

I suspect this is an issue with the Broadcom 802.11ac chipset on the WiFi card. As usual, when there is a new standard like .ac there are compatibility issues with other vendors. Sometimes it can be addressed by a firmware update, other times it's a design fault in the silicon. Who knows what the issue is, but it seems widespread and is not fixed yet, so it may be a silicon fault and never be fixed, short of a recall. This is a good reason to stay away from first revs of a new standard.

bellang
Aug 20, 2013, 12:44 PM
hi, as posted on the apple discussion boards, for those that are having issues (or not!), could you post your wireless card firmware version. It appears to be following the pattern of:

Working MBA: Broadcom BCM43xx 1.0 (6.30.223.74.22)
Faulty MBA: Broadcom BCM43xx 1.0 (6.30.223.74.35)

(from https://discussions.apple.com/message/22775124#22775124 )