PDA

View Full Version : Wi-Fi adapter makes normal connection in OSX, But 'limited' one in Windows 8 ?




JollyJoeJoe
Aug 7, 2013, 06:44 PM
Can't get a working connection to my gateway router in Windows, the same router works fine and connection is normal, working one in OSX. Using the new MacBook Air mid 2013 model.

When I connect to it in Windows 8, it's flagged as 'limited', no internet connection available. Have tried uninstalling\re-installing wi-fi adapter drivers in device manager to no avail. It's probably some freaky incompatibility between the current Windows broadcom driver and the broadband router, any ideas on how to fix it would be great.

I have yet to try it with a different router, but even if it works with a different one I don't think that warrants a router change, a router that otherwise works perfectly fine when the machine is booted into OSX.






Maybe there's something in the way I installed Windows ? But it boots fine and all the drivers have been installed.

- I run bootcamp assistant, let it create a bootable USB stick with Windows 8 installation files from an official ISO.

- Let assistant download latest Bootcamp drivers, I believe they are 5.0.5241 and the assistant backs them up to a different USB stick.

- Let assistant create a partition for Windows and then the machine auto-restart and boots into Windows 8 setup.

- In setup when I get to the partition/volume selection screen it tells me that it can't install Windows on the partition that bootcamp created (titled: Bootcamp) as it's not NTFS. So I format the partition in NTFS using the available options. Following which the 'next' button is no longer disabled and I can proceed to install Windows 8.

- Windows 8 installs fine.

- I run the setup.exe in the bootcamp directory on the flash drive the assistant created. Everything installs fine and all devices appear in device manager.
The machine picks up the available wi-fi networks fine, but when I connect to my wi-fi network that works perfectly in OSX it's flagged as limited and the internet won't work. I tried re-isntalling bootcamp, uninstalling broadcom drivers etc. to no avail same thing.



teffers
Aug 9, 2013, 02:15 AM
Hi Joe,

I, and several other users are having a similar issue in Windows 7.

The wifi adapter seems to either not find any available networks, or, it connects but with limited connectivity.

Some people are reporting success by cold booting into Windows. Meaning not booting into your windows partition by restarting in OSX, but rather using the 'Hold ALT key at start up' method and choosing the bootcamp partition.

For me personally that hasn't worked.

There are some other threads that may be worth a look:

http://forums.macrumors.com/showthread.php?t=1614857

http://forums.macrumors.com/showthread.php?t=1617807

I haven't found a solution for me yet unfortunately - this is all assuming it's a similar issue to yours in Win8.

Mrbobb
Aug 9, 2013, 02:19 AM
When Windows says "limited connection" it means it cannot get an IP from the DHCP server.

Try to give it a static address, see if that's the prob.

teffers
Aug 9, 2013, 02:36 AM
That's true, but having no I.P is the end result of the issue.

I Always use a static I.P for my MBA, so that fix hasn't worked in my case, it may work for Joe though (worth a try) :)

beerglass007
Feb 6, 2014, 04:10 AM
Hi

I have the same problem with a new iMac late 2013 with the new .ac wifi

I'm running windows 7 pro 64bit

It will connect then randomly get limited access

Did you manage to resolve this issue, I called Apple and they blame Windows 8-)

teffers
Feb 6, 2014, 07:29 AM
I never did unfortunately. I gave up trying as I only very occasionally use bootcamp.

It's bizarre because at work it connects fine in Windows 7 but at home, it fails as always.

I suspect it's something related to how the wireless adapter negotiates with different wireless router / ap solutions.

Sorry I couldn't be more help.