PDA

View Full Version : Losing Diskspace Quickly




Mork
Aug 9, 2013, 07:06 PM
I noticed when doing a "Shrink Disk" in VM Fusion 4, that my computer's diskspace was actually *increasing* by the size of the VM each time I did a shrink. Disk spaced used went from 130 GB to 186 GB after two "shrink" attempts.

Since I knew the problem file was in some system folder since the missing disk space wasn't showing up in any Spotlight-based search tools or in DaisyDisk disk tool, etc., I had to use Terminal to further diagnose.

Doing some "ls" commands, I found a directory under the root called: ".MobileBackup" which had orphaned copies of the VM -- three sets in fact.

My other Mac doesn't have this folder at at all (the MBP has it, the iMac does not).

In any case, after doing a remove of all the vmdk files in the .MobileBackup folder, I recovered the missing disk space. I didn't realize there were other orphaned copies of the VM there. I'm now back down to 70 GB.

I have no idea what is going on here.

When I was working in the VM earlier on the MBP (XP Pro) it seemed to be unhappy (slow, needed a reboot) and the problem "shrinks" started happening after that.

Can anyone shed any light on what might have happened? For the moment, I've just removed Windows from the MBP.

Not sure what the /.MobileBackup folder is, but I seem to have fixed the problem - at least until I re-install the VM and try to "shrink" again... :(

I appreciate any advice.

Thanks,

- m



AlanShutko
Aug 9, 2013, 07:11 PM
This is part of Mobile Time Machine. It makes local copies of things and when you run a normal time machine backup, it syncs and coalesces the backups.

The benefit of this is that you can enter time machine and look at previous versions even if you are not on your home network or don't have your time machine drive connected.

This does take disk space but the OS will automatically remove backups (starting with the oldest) when your computer gets low on space. I can't remember if it happens at ten or twenty percent.

davidlv
Aug 9, 2013, 10:39 PM
You can use the Terminal and the following command to turn that off, if you want. I use CCC for backups, and turn TM off completely.
Disable Time Machine local backups
This setting gets changed back to "ON" every time Time Machine is turned on or off .....
sudo tmutil disablelocal

Mork
Aug 10, 2013, 06:53 AM
This is part of Mobile Time Machine. It makes local copies of things and when you run a normal time machine backup, it syncs and coalesces the backups.

The benefit of this is that you can enter time machine and look at previous versions even if you are not on your home network or don't have your time machine drive connected.

This does take disk space but the OS will automatically remove backups (starting with the oldest) when your computer gets low on space. I can't remember if it happens at ten or twenty percent.

Thanks for your reply.

The problem though is that I'm not doing a TM backup. I was just starting Windows VM via VM Fusion. Initially, VM Fusion/Mac OS makes a copy under /.MobileBackups of the VM image.

Then, when I "shrink" the image in Windows using the Virtual Machine's applet there, yet another image gets created in /.MobileBackups.

Turning off TM seems to have fixed it. Still not sure why it was happening.

Thanks for all the replies. :)

-- m

AlanShutko
Aug 10, 2013, 09:04 AM
It is working as it is supposed to.

You have a few options. One, don't worry about it. The OS will delete backups automatically if you run low on disk space so you don't need to micromanage it.

Option two: turn off mobile backups as mentioned above.

Three: exclude the VM from time machine.