PDA

View Full Version : Multiple Terminal windows




ChrisBedford
Aug 11, 2013, 04:20 PM
Mac Rumours forum post

I have searched here and elsewhere and the only references I have found are people wanting to know how to open a second copy of the Terminal command line. I have the opposite problem: when you click on the Application icon in Applications -> Utilities, about 73 instances of Terminal all open at once.

OK I don't know if it's 73 or 53, 123 - didn't have time to count them, but when you right-click the Dock icon the list of "Terminal - bash - 80x24"s goes off the top of the screen. The active one is about 8 up from the bottom of that list. Really odd.

They all respond (thank heavens) to the Quit option on that menu.

So what has happened? Looks like finger trouble, I'm sure, since the current owner of this machine is not exactly - ermm - a computer whiz-kid, and the previous owner was probably even less clued up. The current owner just renamed the user account and carried on (yes I know that is part of the problem and I can probably fix it by creating a new account and starting from scratch, but that is going to take time. For now I want the quick fix!)

Where are the startup options for Application icons - you can't access them with a right-click, I discovered... not even once they are running. :confused:



tag
Aug 11, 2013, 04:27 PM
Only thing that comes to mind is do you have a "Window Group" profile saved perhaps? With terminal open, from the menubar click, Terminal > Preferences, then click the "Window Group" tab. Is there anything listed in those fields? If so delete them.

You can also make sure that no Window Groups are being activated at startup by again from menubar clicking Terminal > Preferences, then under the Startup tab, make sure that "On startup open:" "New Window with Settings" is chosen, and not "Window Group".

ChrisBedford
Aug 12, 2013, 02:28 AM
Only thing that comes to mind is do you have a "Window Group" profile saved perhaps? With terminal open, from the menubar click, Terminal > Preferences, then click the "Window Group" tab. Is there anything listed in those fields? If so delete them.

You can also make sure that no Window Groups are being activated at startup by again from menubar clicking Terminal > Preferences, then under the Startup tab, make sure that "On startup open:" "New Window with Settings" is chosen, and not "Window Group".

Thanks Tag

I will check these out this week and see what happens!

Dalton63841
Aug 12, 2013, 03:29 AM
Sounds more like Lion's( and newer) auto restore window "feature". It's a supreme annoyance. It can be turned off by checking "Close windows when quitting an application" in the General section in System Preferences. After that you may need to launch it and close the windows and quit the app one last time, and then it should honor the setting.