PDA

View Full Version : Cloning & Moving Partition Causing Most Apps to Crash




paintballmjm
Aug 12, 2013, 12:27 AM
Hi everyone :)

For a while, I had free space from an old deleted primary partition, with the free space existing *above* the new partition in Disk Utility. Since the space was above the new partition in the list, it couldn't be used to add to the partition. So I made a new partition where the free space was, cloned the existing one to it with Carbon Copy Cloner, and then resized the partition.

Unfortunately, almost every single app is now crashing at launch, with some exceptions being Apple-related apps (Mail, Safari, System Preferences, etc.) Neither Disk Utility nor Onyx has reported any problems. I also tried making a new user account to no avail. My theory is that since the data was moved to a new physical part of the disk, there might be an issue with hard links, but I'm no expert on that.

Does anyone have any solutions for this? I'm on DSL so Internet Recovery is my last resort ;)

Thanks!

(P.S. Console has been spamming these two messages several times per second -
Just checked Console and it's spamming these two messages several times per second -

ReportCrash[3452]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

ReportCrash[3452]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0