PDA

View Full Version : Backlit keyboard




gabe.
Aug 13, 2013, 09:52 PM
The backlit keyboard on my 2013 MBA seems to be acting up.

When I awake it from sleep, it usually does not come on. However, occasionally it does.

Any idea on what may be the issue and solution here? I've tried messing with the keyboard and energy saver options to no success. Also tried a system restart.

Thanks

EDIT: Should I reset the SMC? Are there any risks/reasons not to do this?



lina231
Aug 14, 2013, 10:46 PM
The backlit keyboard on my 2013 MBA seems to be acting up.

When I awake it from sleep, it usually does not come on. However, occasionally it does.

Any idea on what may be the issue and solution here? I've tried messing with the keyboard and energy saver options to no success. Also tried a system restart.

Thanks

EDIT: Should I reset the SMC? Are there any risks/reasons not to do this?

The only time the keyboard doesn't light up is when there is enough light for you to see the keyboard. So, this may sound dumb, but just make sure the light where you're at is off or dim enough so that the keyboard light comes on. My boyfriend was freaking out about this same problem and it turns out it was actually just the lighting:rolleyes:

M0V3M3N7
Aug 15, 2013, 11:17 AM
The backlit keyboard on my 2013 MBA seems to be acting up.

When I awake it from sleep, it usually does not come on. However, occasionally it does.

Any idea on what may be the issue and solution here? I've tried messing with the keyboard and energy saver options to no success. Also tried a system restart.

Thanks

EDIT: Should I reset the SMC? Are there any risks/reasons not to do this?

The backlighting only comes on when the light sensor in the keyboard senses it is dark enough for you to need it.

If you want to manually adjust it, use the buttons at the back of the keyboard! There is no way that I know of to make sure it is always on - but when there is plenty of light in the romm you are in, surely you dont need it!

M5RahuL
Aug 15, 2013, 12:15 PM
Open Preferences >> Keyboard >> Uncheck ' Adjust Keyboard brightness in low light '

Also, set the ' Turn off when the computer is not used for : ' slider to ' Never '


That should take care of the issue, if there is one to begin with :apple: