PDA

View Full Version : External HD read only




tarsierspectral
Aug 15, 2013, 08:44 PM
Hi,

I was using my external HD then I rebooted my computer and then the drive all of the sudden became read-only. Anyone know why and how to fix it?

Thanks



Fishrrman
Aug 16, 2013, 09:26 AM
What type of format (Mac or PC) is the external drive?
What kind of partition map are you using?

ColdCase
Aug 16, 2013, 03:48 PM
Something like this has happened to me a couple times with FAT 32 drives. Usually a reboot of the mac fixed the issue. Otherwise, perhaps copy all the files elsewhere for safe keeping, run disk utility to repair drive, if that doesn't work, reformat the drive and copy the files back onto it.

But the right thing to do starts with how the drive is currently formatted (Mac or PC)

GGJstudios
Aug 16, 2013, 04:08 PM
Hi,

I was using my external HD then I rebooted my computer and then the drive all of the sudden became read-only. Anyone know why and how to fix it?
As others have indicated, it would be helpful to know what the format of the drive is. Also, if it is NTFS, what software are you using to enable reading and writing to it?

Format A Hard Drive Using Disk Utility (http://macs.about.com/od/applications/ss/diskutilformat_4.htm) (which is in your /Applications/Utilities folder) Choose the appropriate format:  HFS+ (http://en.wikipedia.org/wiki/HFS%2B) (Hierarchical File System, a.k.a. Mac OS Extended (Journaled) Don't use case-sensitive) Read/Write HFS+ from native Mac OS X Required for Time Machine (http://support.apple.com/kb/HT1427) or Carbon Copy Cloner (http://www.bombich.com/) or SuperDuper! (http://www.shirt-pocket.com/SuperDuper/SuperDuperDescription.html) backups of Mac OS X system files. To Read/Write HFS+ from Windows, Install MacDrive (http://www.mediafour.com/products/macdrive/) To Read HFS+ (but not Write) from Windows, Install HFSExplorer (http://www.catacombae.org/hfsx.html) Maximum file size: 8EiB Maximum volume size: 8EiB Mac OS X: Mac OS Extended format (HFS Plus) volume and file limits (http://support.apple.com/kb/HT2422) You can use this format if you only use the drive with Mac OS X, or use it for backups of your Mac OS X internal drive, or if you only share it with one Windows PC (with MacDrive installed on the PC) NTFS (http://en.wikipedia.org/wiki/Ntfs) (Windows NT File System) Read/Write NTFS from native Windows. Read only NTFS from native Mac OS X To Read/Write/Format NTFS from Mac OS X, here are some alternatives: For Mac OS X 10.4 or later (32 or 64-bit), install Paragon (http://www.paragon-software.com/home/ntfs-mac/) (approx $20) (Best Choice for Lion and later) For 32-bit Mac OS X, install NTFS-3G for Mac OS X (http://macntfs-3g.blogspot.com/2010/10/ntfs-3g-for-mac-os-x-2010102.html) (free) (does not work in 64-bit mode) For 64-bit Snow Leopard, read this: MacFUSE for 64-bit Snow Leopard (http://www.offthehill.org/articles/2010/12/31/macfuse-for-64-bit-snow-leopard/) Some have reported problems using Tuxera (http://www.tuxera.com/products/tuxera-ntfs-for-mac/) (approx $36). Native NTFS support can be enabled in Snow Leopard and Lion, but is not advisable, due to instability. AirPort Extreme (802.11n) and Time Capsule do not support NTFS Maximum file size: 16 TB Maximum volume size: 256TB You can use this format if you routinely share a drive with multiple Windows systems. exFAT (http://en.wikipedia.org/wiki/Exfat) (FAT64) Supported in Mac OS X only in 10.6.5 or later. Not all Windows versions support exFAT. See disadvantages (http://en.wikipedia.org/wiki/Exfat#Disadvantages). exFAT (Extended File Allocation Table) (http://en.wikipedia.org/wiki/ExFAT) AirPort Extreme (802.11n) and Time Capsule do not support exFAT Maximum file size: 16 EiB Maximum volume size: 64 ZiB You can use this format if it is supported by all computers with which you intend to share the drive. See "disadvantages" for details. FAT32 (http://en.wikipedia.org/wiki/Fat32#FAT32) (File Allocation Table) Read/Write FAT32 from both native Windows and native Mac OS X. Maximum file size: 4GB. Maximum volume size: 2TB You can use this format if you share the drive between Mac OS X and Windows computers and have no files larger than 4GB.

tarsierspectral
Aug 16, 2013, 07:34 PM
The drive format is Mac OS Extended. Have been using is strictly on my iMac and strictly to edit in Final Cut X.

ColdCase
Aug 17, 2013, 08:39 AM
Have you tried the simple things like ejecting the HD, unplug and plug it back in, or reboot with and without the drive connected?

Have you tried using disk utility, select the drive from the list and select repair permissions or repair disk?

Did you have Carbon Copy Cloner or similar running? SOmetimes these BU programs leave a disk in a strange state if they are interrupted.

Fishrrman
Aug 17, 2013, 09:12 AM
[[ The drive format is Mac OS Extended. Have been using is strictly on my iMac and strictly to edit in Final Cut X. ]]

OK, then, try this:

Close all windows on the external -- you should see only the drive icon on the desktop

Click ONE time on the drive icon to select it, then type "command-I" to "get info" on the drive.

Examine the "get info" box. Toward the bottom, there is a "sharing and permissions" area. If the disclosure triangle is not pointing down, click it so it reveals the details.

At the extreme lower-right corner, there should be a "lock icon". Click on it and enter your adminstrative password.

At the extreme lower-left of the get info box you should see a checkbox "ignore ownership on this volume". Make sure there is a checkmark next to it.

Now close the get info box.

Try writing to the drive now.
What happens?

tarsierspectral
Aug 19, 2013, 07:42 AM
[[ The drive format is Mac OS Extended. Have been using is strictly on my iMac and strictly to edit in Final Cut X. ]]

OK, then, try this:

Close all windows on the external -- you should see only the drive icon on the desktop

Click ONE time on the drive icon to select it, then type "command-I" to "get info" on the drive.

Examine the "get info" box. Toward the bottom, there is a "sharing and permissions" area. If the disclosure triangle is not pointing down, click it so it reveals the details.

At the extreme lower-right corner, there should be a "lock icon". Click on it and enter your adminstrative password.

At the extreme lower-left of the get info box you should see a checkbox "ignore ownership on this volume". Make sure there is a checkmark next to it.

Now close the get info box.

Try writing to the drive now.
What happens?
Yes, these are the first things are I tried. "Ignore ownership of this volume" is already checked. I can't write to the drive.

----------

Have you tried the simple things like ejecting the HD, unplug and plug it back in, or reboot with and without the drive connected?

Have you tried using disk utility, select the drive from the list and select repair permissions or repair disk?

Did you have Carbon Copy Cloner or similar running? SOmetimes these BU programs leave a disk in a strange state if they are interrupted.

Tried all of that except the disk utility until I copy all the files off of it. I don't want to risk damaging the drive by running the disk utility until I have a full back up. Thanks

Fishrrman
Aug 19, 2013, 08:56 AM
I found the following in my archives.
I didn't write it.
I'm just re-posting it -- perhaps it may help:
========================================
I called Apple and they gave me the solution :

http://discussions.apple.com/thread....35132�

Quote:
I found a solution that worked.

In Terminal type the following sequence (obviously replace "Volumename with the name of your volume):

sudo chflags 0 /Volumes/Volumename
sudo chown 0:80 /Volumes/Volumename
sudo chmod 775 /Volumes/Volumename
sudo chmod -N /Volumes/Volumename
but if your hard drives name includes a [space] like this: "My HD", then you must write the command like this:

Quote:
sudo chflags 0 /Volumes/firstname\ secondname
sudo chown 0:80 /Volumes/firstname\ secondname
sudo chmod 775 /Volumes/firstname\ secondname
sudo chmod -N /Volumes/firstname\ secondname
or like in my example:

Quote:
sudo chflags 0 /Volumes/My\ HD
sudo chown 0:80 /Volumes/My\ HD
sudo chmod 775 /Volumes/My\ HD
sudo chmod -N /Volumes/My\ HD
It saved both my drives! THANK YOU APPLE!!!



Originally Posted by angelwatt
Thanks for posting the solution you found.

Just to give some more info, for those who care, about the above commands I'll give a brief description of what each line does (as I understand them).
chflags 0 removes all flags from the file(s)
chown 0:80 ensures root:admin (owner:group) permissions so the system can access the files
chmod 775 adjusts file permissions so you and your group have read/write/execute permissions
chmod -N removes the ACL (Access Control Lists) from the named file(s)